0

I've just installed VS Code and added Cmder as a default terminal on a new Win10.

I am trying to import my git for Windows .bashrc aliases to be used with Cmder. So I've added them to user_aliases.cmd.

Example alias:

make=./bin/webpack-make.sh

If I run Cmder separately, aliases scripts run OK. When I run them trough the VS Code terminal, I get this message:

λ dev '.' is not recognized as an internal or external command, operable program or batch file.

If I add the full path I get:

λ dev The system cannot execute the specified program.`

Any Ideas why is this happening?

btw, I've added Cmder and VSCode with Scoop.

0

Cmder (actually the ConEmu) is a terminal. But you are trying to configure aliases for use by shell (cmd.exe I believe). The difference is described here.

You have two options:

  • Run bash in Cmder (ConEmu) and use aliases as usual in bash. To do that just choose appropriate startup shell Settings/Startup
  • Modify the alias to run sh-script via bash. Sort of make=sh.exe -c ./bin/webpack-make.sh
| improve this answer | |
  • Hey, thanks for giving some tips. I have tried those and they don't fix the issue for now. Will try stuff and get beck if anything works. The thing is If I run Cmnder naively a with {bash::bash} all is OK, all aliases work fine. If I run in in VSCode, git aliases work fine but not the .sh scrips. – idm May 3 at 18:14
  • Look at StatusBar. It shows what shell you actually started. I believe it's not bash. – Maximus May 3 at 21:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.