2

Host: Debian 10

Guest: Windows 10

Hypervisor: Virtualbox 6.0.x

GPU: Nvidia Quadro 5000

Long story short: VT-d compatible chipset, IOMMU enabled, PCI-passthrough enabled, etc., and I as far as the point where guest Windows detects the graphics card and installed driver, but only to encounter the infamous code 43 problem, which in this case arose because the driver detects that the machine is running on a hypervisor and disables the graphics card. On QEMU there is an easy workaround to disguise the hypervisor, which simply spoofs the vendor id for the hypervisor. From this solution, it's easy to deduct that the driver detects the hypervisor soely based on vendor id, as opposed to other tells (e.g. virtual hardware). Hence the question: is there a simple way to spoof the VirtualBox hypervisor's identity?

1
  • I should add that I'm avoiding migrating to QEMU due to single-user licensing of some software installed on the guest.
    – seamux
    May 4, 2020 at 7:02

1 Answer 1

0

You shouldn't need any workarounds for a Quadro 5000. Back in the day (this is a Fermi based card similar to a GTX470 if I am not mistaken), I used to soft-mod GTX470s into Quadro 5000s specifically so that I could use them with VMs, without having to disable Windows driver signing to use a modified driver.

4
  • Thank you. The issue is, though, that the NVidia driver blocks VMs since v337.88 and the most current driver for Quadro is v390.xx. I tried installing v304.xx to no avail, likely due to that v304.xx only supports up to Windows 7.
    – seamux
    May 4, 2020 at 17:00
  • Interesting, I wasn't aware they pulled VM support for Fermi Quadros. You could try older drivers from the archives from Guru3D: guru3d.com/files-get/… IIRC the driver model hasn't changed between Windows 8 and 10. May 4, 2020 at 19:27
  • I successfully installed an earlier driver but the issue persists. The VM is headless; on Linux without specifically setting up for headless Nvidia GPU the driver doesn't load, and I suspect it's something similar on Windows. I could get a display emulator plug and try again, but decided to give up and got an AMD card, which works great, and I'll leave the Nvidia GPU on the host system for video encoding and CUDA tasks. Thanks again for looking into it!
    – seamux
    May 8, 2020 at 16:14
  • You should be aware that AMD cards have a bug which means they don't handle VM reboots properly. You have to "eject" the card before shutting down the VM to get them to work. May 8, 2020 at 16:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.