0

I am a PhD student working on my dissertation in an historically-oriented discipline, which requires me to frequently type in a variety of languages, including Latin and Greek. I am frustrated that Word constantly changes the font that I am using whenever I change my keyboard layout to Greek Polytonic. This isn't a problem when using Calibri, because Calibri is the font that it changes to. But when I am using other fonts (including, but not limited to, one that I designed myself in order to solve certain citation problems), as soon as I switch to the Greek keyboard layout, the font changes back to Calibri. I have changed the default font of the document to the one that I want to use, and it does not solve the problem. The problem is also not in the font itself, which has all the necessary Greek letters. If I go ahead and type the Greek in Calibri anyway, and then highlight it and change it to the font that I was using, it works fine and looks fine. But the active font in which I am type always automatically changes to Calibri when I change to the Greek keyboard layout.

I have looked around, and I see that this is a common problem. I have tried every solution that anyone has proposed, and nothing works. To be clear, this font change does not occur when I type the first Greek character (as sometimes happens when you try to insert a special character that doesn't exist in the font you are using); it happens at the exact instant that I switch keyboard layouts, before I type anything. It seems very unlikely that this is a bug: it seems very much like a deliberately programmed feature, which would be useful to most people under most circumstances, but is a serious problem for me. Surely, there must be some way to disable this feature (much as you can disable autocorrect features?).

I have seen that in older versions of Word, there is a checkbox in the Preferences menu to match the font to the keyboard layout, but I cannot find this in Word 365 (I can find the opposite function, to change keyboard layouts when the language changes, but this is not helpful to my problem).

The closest answer that I have found is here: Word automatically switches to Times New Roman whenever I type using a German keyboard layout This solution suggests that the problem is not the keyboard layout, but the fact that the keyboard layout is included within a different language (in that case, the user is trying to use a German keyboard layout and has accessed this keyboard layout from the German language pack on Windows). The solution for that user was to not use the German keyboard layout within the German language pack, and instead install the German keyboard layout within the English (US) language pack.

This solution will not work for me, however, as the Greek Polytonic keyboard layout is not available in the English (US) language pack, nor my Canadian English language pack. Only the Greek-Latin keyboard layouts are available, which transliterates Greek into our alphabet, which defeats the purpose.

Does anybody know of a way to either disable this feature in Word or to add a Greek Polytonic keyboard layout to the English language pack?

0

Some users reported that it seems to be related to style settings in the global template file of Word. You can try renaming Normal.dotm from %userprofile%\Application Data\Microsoft\Templates\.

When you rename the Normal.dotm template in Word, you reset several options to the default settings. These include custom styles, custom toolbars, macros, and AutoText entries.

For more information, read the thread:Microsoft Word switches fonts when I switch input language.

Reference: Word changes font on some language specific characters while writing

Change the default font in Word

How to reset user options and registry settings in Word

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.