2

I need to use an old Ubuntu distribution (10.04) 32bit for compatibility reasons. I have to run it in hyper v, thus i need to get a SSH connection to the system up and running.

I adjusted the /etc/apt/sources.list to include old-releases.ubuntu.com so that i can update and upgrade.

When Trying to install ssh-server / openssh-server using

sudo apt-get install ssh-server
sudo apt-get install openssh-server

the following message is shown:

packet ssh-server has no installation candidate

Any suggestions on how to install either ssh-server or openssh-server on this machine?

Any help or workarounds are appreciated!

5
  • May be it is easier to just download an stand-alone ssh server like Dropbear and install it manually?
    – Robert
    May 6 '20 at 13:49
  • Can you find the package in apt-cache search ssh?
    – user1686
    May 6 '20 at 14:18
  • 1
    Ask Ubuntu might be a better place to ask.
    – Kenster
    May 6 '20 at 14:38
  • Up through v. 16.04 LTS, there were 32-bit versions (and upgrade from 16.04 32-bit to 18.04 32-bit is possible). You might try a live USB with a later version of Ubuntu to see if it's compatible with your SSH needs. May 6 '20 at 18:42
  • @Kenster it wasn't, though. Actually AskUbuntu is rather strict about what's on-topic. Heck questions about upcoming releases can be off-topic one hour and on-topic the next. Also they don't care about Ubuntu derivatives, which is ironic, looking at Ubuntu as Debian-derivative. And for Mint so many things apply to Ubuntu out of the box. Oh and last but not least I find AskUbuntu more rude and less appreciative of questions and answers alike than other SE sites I frequent (less upvotes, even less on questions). May 11 '20 at 12:32
2

First off, back that VM up.

Please, follow these steps bellow:

  1. try to run sudo apt-get update (To update your package repository).
  2. Then, try to run sudo apt-get install openssh-server (To install the ssh server).

Important Note: Don't need run sudo apt-get install ssh-server because just sudo apt-get install openssh-server enough to install the full ssh server.

Follow a copy of /etc/apt/sources.list file content bellow:

deb http://old-releases.ubuntu.com/ubuntu/ lucid main restricted
deb-src http://old-releases.ubuntu.com/ubuntu/ lucid main restricted
deb http://old-releases.ubuntu.com/ubuntu/ lucid-updates main restricted
deb-src http://old-releases.ubuntu.com/ubuntu/ lucid-updates main restricted
deb http://old-releases.ubuntu.com/ubuntu/ lucid universe
deb-src http://old-releases.ubuntu.com/ubuntu/ lucid universe
deb http://old-releases.ubuntu.com/ubuntu/ lucid-updates universe
deb-src http://old-releases.ubuntu.com/ubuntu/ lucid-updates universe
deb http://old-releases.ubuntu.com/ubuntu/ lucid multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ lucid multiverse
deb http://old-releases.ubuntu.com/ubuntu/ lucid-updates multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ lucid-updates multiverse
# deb http://old-releases.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse
# deb-src http://old-releases.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse
# deb http://old-releases.canonical.com/ubuntu lucid partner
# deb-src http://old-releases.canonical.com/ubuntu lucid partner
deb http://old-releases.ubuntu.com/ubuntu lucid-security main restricted
deb-src http://old-releases.ubuntu.com/ubuntu lucid-security main restricted
deb http://old-releases.ubuntu.com/ubuntu lucid-security universe
deb-src http://old-releases.ubuntu.com/ubuntu lucid-security universe
deb http://old-releases.ubuntu.com/ubuntu lucid-security multiverse
deb-src http://old-releases.ubuntu.com/ubuntu lucid-security multiverse

Here in my VM these steps worked very well.

6
  • 1
    Thanks, that worked for me. It seems like i did not fully fix the /etc/apt/sources.list.
    – Bassrelic
    May 11 '20 at 12:04
  • 1
    @Bassrelic you should upvote in addition to accepting, if this really helped you. May 11 '20 at 12:34
  • 1
    @ 0xC0000022L i did but i had not the previleges for it to be shown (possible that i removed the vote by klicking twice though) Sorry for that!
    – Bassrelic
    May 11 '20 at 12:39
  • @jluizsouzadev just one remark, applying sed to do the replacement would have been more sensible, simply because you don't know which lines were originally enabled or not for the OP. Basically something along the lines of sed -i.bak -E 's|://[a-z0-9\.]+/ubuntu|://old-releases/ubuntu|g' /etc/apt/sources.list May 11 '20 at 12:40
  • @Bassrelic yep, clicking again removes the vote unless it has been locked (which happens after 5 minutes or so ... and can be undone if the post - question or answer - gets edited again). May 11 '20 at 12:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.