1

Recently, my micro SD card stopped showing up in Explorer on my Surface pro 6. I opened the Disk Management tool and the disk does get recognized (as Disk 1 below), but the main partition does not have a letter, and I can not access its properties or do any changes to it.

I did not do anything to the SD card and have no idea how the letter (D:/) disappeared from it. I have many important files on it.

enter image description here

when I right click on the Disk 1 label and click "Change Drive letter and paths", it gives me this message:

enter image description here

I tried removing the device and reinserting it, and restarting my computer, nothing works. Is there a way to restore it?

  • Do you have any other devices you could try inserting the SD card into? – Tim G. May 7 at 1:16
  • @TimG. Yes, I tried another computer and had the same result – Victor2748 May 7 at 3:24
  • 2
    Golden Rule: Never entrust the only copy of any data to something so delicate as an SD card. They have a stupendously high fail-rate. If the data on it was truly valuable, stop messing with it & send it to a data recovery professional. If not, then just bin it & get a new one. They're not worth fighting once they start to play up. – Tetsujin May 7 at 5:59
  • Neither of the partitions on your Sd card have a filesystem. Either your card has failed, which would not be a surprise at all, or you have accidentally wiped it somehow. If formatting doesn't fix it then you should throw it out and get a new one. As Tetsujin says you should never have anything you can't afford to lose on an SD card. – Mokubai May 7 at 7:29
1

What is the actual size of the microSD card? It shows as having two partitions, one of 16 MB, another of 119 GB, and neither have a file system. Did you intentionally create a second partition? That can also happen during attempted use of the card as boot media when an application such as Rufus creates a separate boot partition. In any case, it's puzzling that there is no file system in either partition.

In order to use the disk, a file system must be written to the card. Unless you have a need for two partitions, do the following, using Windows Disk Management or a third-party tool such as free DiskGenius, which offers greater capability (e.g. extx file system).

  • Delete both partitions, creating ~135 GB free space.
  • Create a single partition using all that space.
  • Create a file system. For flash memory in microSD cards, FAT32 or exFAT is suggested.
  • Test writing and reading a few GB with the card to be sure it is not damaged.
| improve this answer | |
  • @Victor2748 - You need to edit your question instead of submitting a temporary comment. The larger partition according to Disk Management has absolutely no data on it. – Ramhound May 7 at 7:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.