1

After replacing my hard drive with an SSD, and adding a second hard drive, my front USB ports aren't working anymore.

What I've tried so far:

  • Restarting my computer, numerous times
  • Uninstalling USB drives and allowing them to reinstall on reboot
  • Checking if my USB 2.0 and 3.0 ports were enabled in bios; they are
  • Checking if my front USB ports are still plugged in; they are

I'm not sure what else to try, so any help would be really appreciated.

My OS is running on the SSD so i can't remove it.

Edit: I think I may have found the issue. In Device Manager above USB controllers is "IEEE 1394 host controllers" with "1394 OHCI Compliant Host Controller (Legacy)" under it. It has a yellow triangle with an exclamation mark so clearly there is something wrong with that but it won't let me update the driver.

When I try to update the driver I get this error: https://i.imgur.com/tAUuemi.png

My system info:

Motherboard - ASUS P6X58-E PRO LGA 1366 Intel X58 SATA 6Gb/s USB 3.0 ATX Intel

Graphics Card - Nvidia GTX 660

CPU - Intel® Core™ i7-950 Processor

Hard drives:

WD Blue 500GB SSD (WDS500G2B0A)

WD Blue 4TB Hard Drive (WD40EZRZ)

and my power supply is 600W

8
  • Temporarily remove the SSD to see if that is the cause (e.g. uses too much current to enable USB ports). You can run from a live USB drive to test without having to reinstall the original setup. May 7, 2020 at 22:04
  • 1
    You seem to have created two accounts. You should merge the two. superuser.com/help/merging-accounts
    – Dave M
    May 8, 2020 at 19:52
  • @DaveM thanks, I didn't realise that was an option.
    – Red
    May 9, 2020 at 3:58
  • Is it an NVMe SSD? If so, please add the make and model of the motherboard because some M/Bs have limited PCIe lanes to allocate to the various ports. If you are not using the Firewire (IEEE 1394) port(s), you may be able to disable them in the BIOS. May 9, 2020 at 16:40
  • are you sure no physical connector came loose when you installed the SSD? Have you checked? Sonetimes it's a question of 1/10th of a millimeter. Or you have just pulled the cable a little bit without noticing
    – 1NN
    May 9, 2020 at 18:16

1 Answer 1

0

Your issue definitely sounds like a driver problem. What you can do is trying to install the driver yourself. Unfortunately it seems your motherboard is quite old. The only drivers I could find for your front usb ports are for windows 7. Sometimes you can still use drivers that were for older version of windows. The two places I have found where you can get the drivers is the official asus website and win-raid.

https://www.asus.com/us/Motherboards/P6X58E_PRO/HelpDesk_Download/ select windows 7 64bit as your OS and you can find the USB drivers

or if you want more slightly updated drivers https://www.win-raid.com/t834f25-USB-Drivers-original-and-modded.html

go down to Renesas expand the spoiler and you will want the Gen1 USB 3.0 drivers.

Recommend that you try the official drivers first before attempting to use a driver from un-official sources. The goal is to get the drivers installed and working so that windows 10 can see it properly and hopefully update it if it has better drivers. The worst that happens is you still have no front usb ports to use.

2
  • I installed the first drivers successfully and nothing changed. I tried installing the Renesas drivers but got this error: i.imgur.com/UGRSLER.png
    – Red
    May 17, 2020 at 15:28
  • While I am late to this comment, it could be that your usb ports have died or are in the process of dying. Sometimes this happens. If the official drivers installed successfully and windows still can't make use of the ports, it just might be hardware related and not OS related. What you could try is install the official drivers and then see if windows can update the drivers after that since it is able to see its type.
    – Frostalf
    May 28, 2020 at 0:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.