0

I have an old laptop that I installed Linux on, overwriting Windows. I am currently trying to reinstall Windows 10, but I'm running into some issues. My installation media is a bootable USB created using these instructions.

When I attempt to partition the hard disk and click Next to continue with the install, I'm greeted by the following error message:

We couldn't create a new partition or locate an existing one. For more information, see the Setup log files.

I've tried wiping and repartitioning the disk and manually partitioning it with diskpart. I tried creating an ESP of size 500 MB instead of the default 100 MB. I also noticed that the USB drive was getting assigned the letter C, so I removed it, assigned C: to the primary partition on the disk, and reinserted the USB drive as described here.

So far, no dice. I did manage to grab those log files, though I can't make much sense of them. It seems to me that it can't find the EFI System Partition, but it should be creating one.

I have seen a proposed solution that involves copying the installation files to a partition on the disk, but this seems to only be for MBR. Is there any way to do this on a UEFI system?

EDIT

To clarify, as per @Ramhound's request:

  1. The disk was wiped several times, both by deleting partitions in the GUI and by using the clean command in diskpart.
  2. The disk has been formatted as GPT. Is there anything else that would be necessary for UEFI support?
  3. The firmware has been set to boot in UEFI mode, not Legacy Support mode.

Further system details: This is a Lenovo Y40-70 that originally shipped with Windows 8. Firmware is InsydeH2O.

  • Have confirmed the following is true 1) All partitions on the disk have been deleted. 2) The disk was created to support UEFI. 3) Your system is configured to use UEFI and Legacy/Compatibility Mode is disabled. Instead of replying with a comment, you should edit your question, so it includes the required information necessary to answer your question. – Ramhound May 7 at 21:23
  • @Ramhound Please see the above edit. – 5nefarious May 7 at 22:35
  • “ The disk has been formatted as GPT.” - Which disk exactly? The disk your installing Windows to shouldn’t have any partitions except one unallocated partition – Ramhound May 7 at 22:40
  • @Ramhound The disk I’m installing to. When I click New on the partitioning page, the installer automatically creates a recovery partition, an ESP, a reserve partition, and a primary one. – 5nefarious May 7 at 22:45
0

Here's what worked.

I added the CreatePartition-UEFI.txt DiskPart script described here to the USB drive. Then, at the partitioning page, I used Shift+F10 to open a command prompt and ran that script.

X:\Sources> DiskPart /s D:\CreatePartitions-UEFI.txt

I then created a second EFI System Partition after the primary Windows partition...

DISKPART> select disk 0
DISKPART> select partition <NUM>
DISKPART> shrink minimum=6000
DISKPART> create partition efi
DISKPART> format quick fs=fat32 label="Installer"
DISKPART> assign letter=G

...and copied the install files into the new partition:

X:\Sources> xcopy D: G: /e /h

I then shutdown the machine, removed the USB drive, and booted it. This took me to the installer.

Oddly enough, the install fails, as it seems to be unable to read the install files from the ESP. So, here, I exited back to the beginning of the install, re-inserted the USB drive, and clicked Install again. This time, it seemed to work.

At the partition screen, I selected the primary Windows partition, and clicked Next. I believe I did get a warning about how I was not using the recommended partitioning scheme, but I opted to continue anyway.

And the installation finished!

I'm still unsure about which ESP the machine is booting from, so I don't know if it's safe to remove the second one with the installer on it. At boot, the bootloader does give me the option to boot either "Windows 10" or "Windows Installer."

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.