0

I recently installed lubuntu on new partition, and in doing so, I formatted the efi partition to FAT32. Now I want to boot into Windows 10, but none of the usual recovery methods have worked for me - the efi files are in the efi partition, but nothing seems to recognize them. I can enter the grub menu, so the BIOS boot order is correct. I have tried:

  • theupdate-grub command: it doesn't detect the Windows bootloader. Neither does os-prober.
  • boot-repair utility: it says that it completed successfully, but it still doesn't work. Here is its bootinfo summary.
  • Creating a custom grub entry as described here. It's unable to find the boot files.

I put the boot files into the efi partition by running bootrec and bootsect, and mounting and unmounting the efi partition from a command line in the recovery USB. The recovery files are old - I think they're from Windows 10, but a much older build than the one installed on the drive. Is that what's causing the boot files to not be detected? I don't know what else it could be, since boot-repair finds the efi files in the correct partition (sdb2).

Any help would be much appreciated.

0

The only suggestion I can provide is considering reinstalling windows 10 which means removing lubuntu. The reason for this as a solution is because the system is not recognizing the EFI files even though you are able to see the files on your computer. This could mean the files are hidden (if possible) or not readable by your system. Another option is to contact your computer's manufacturer as they may be able to provide a solution that does not require you to reinstall Windows 10.

Here's an article that provides some information for recovering windows 10: https://support.microsoft.com/en-us/help/12415/windows-10-recovery-options

1
  • I was hoping there would be some other way, but if that's the only option then I guess I'll have to do that. There is no manufacturer - I built the PC myself with a retail copy of Windows May 12 '20 at 4:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.