I have a simple pool of two 1TB drives (HDD) setup in a two way mirror (only one disk created). Yesterday it was showing that 1 TB of the 1.81 TB pool capacity was used. Which sound correct because I had around 500 GB of data on that drive.

This morning (after a nightly windows update (cumulative 2020-05) I got a "low capacity" error. It even showed that 1.81 TB of 1.81 TB was used and all physical drives were at 99.9%

I checked the properties of the drive and it was showing the correct numbers: Property window drive

Also I selected all the files and double checked the total amount used on disk: Property window file selection

The strangest part is that when I copied over a 50 gb test file to that drive, the numbers in control panel changed again. Strangely it dropped down to 1.7 TB, which is still wrong. Pool info control panel

BTW the service/system is working fine. I have a second pool which is giving me the correct information.

I've already tried:

  • Cleaned recycle bin but it did not make any difference.
  • A Chkdsk gave no errors and did also not resolve anything
  • "Optimize drive usage" in control panel had no results
  • I have an ignorant question: with two 1TB drives, how do you get to 16 TB?
    – VWFeature
    Commented Apr 4, 2021 at 15:29
  • @VWFeature That's how storage spaces work. In essence you can create a space as big as you want. When your real physical space is almost full you just add new disks to the storage space. They are virtual volumes!
    – Mumblic
    Commented Apr 22, 2021 at 12:02

2 Answers 2


After a long search I found a solution myself by running the following PowerShell command (administrative privileges)

Optimize-Volume -DriveLetter S -Verbose

Replace S with your drive letter.

I've got the following result back:

VERBOSE: Invoking slab consolidation on RISA (S:)...
VERBOSE: Slab Analysis:  0% complete...
VERBOSE: Slab Analysis:  100% complete...
VERBOSE: Slab Analysis:  100% complete.
VERBOSE: Retrim:  0% complete...
VERBOSE: Slab consolidation was skipped because there were few evictable slabs.
VERBOSE: Retrim:  100% complete.
VERBOSE: Performing pass 1:
VERBOSE: Retrim:  3% complete...
VERBOSE: Retrim:  4% complete...
VERBOSE: Retrim:  5% complete...
VERBOSE: Retrim:  100% complete.
VERBOSE: Post Defragmentation Report:
VERBOSE: Volume Information:
VERBOSE:   Volume size                 = 15,99 TB
VERBOSE:   Cluster size                = 4 KB
VERBOSE:   Used space                  = 581,13 GB
VERBOSE:   Free space                  = 15,43 TB
VERBOSE: Allocation Units:
VERBOSE:   Slab count                  = 65534
VERBOSE:   Slab size                   = 256 MB
VERBOSE:   Slab alignment              = 127,00 MB
VERBOSE:   In-use slabs                = 2326
VERBOSE: Slab Consolidation:
VERBOSE:   Space efficiency            = 100%
VERBOSE:   Potential purgable slabs    = 1
VERBOSE:   Slabs pinned unmovable      = 1
VERBOSE:   Successfully purged slabs   = 0
VERBOSE:   Recovered space             = 0 bytes
VERBOSE: Retrim:
VERBOSE:   Backed allocations          = 3324
VERBOSE:   Allocations trimmed         = 998
VERBOSE:   Total space trimmed         = 249,50 GB

It's clear that the retrim action reclaimed all of my lost pool space. I always thought that "Trim" was something specific for SSD's but in this case it has probably other meanings too. According to microsoft Docs

Generates TRIM and Unmap hints for all currently unused sectors of the volume, 
notifying the underlying storage that the sectors are no longer needed and can be purged.
This can recover unused capacity on thinly provisioned drives.

Because I'm using only two 1 TB HDD's for a 16 TB volume the last part is problay significant here: "This can recover unused capacity on thinly provisioned drives."

I'm going to dive deeper into what "retrim" really does, because it's still somewhat of a mystery why this problem occurred after a Windows update


Can you do the following:

  1. Check if the same error occurs when logged in through a different user account.
  2. Can you give us a chkdsk log since we don't know what chkdsk did. Were there errors?

The cause of this error is likely to be a System Corruption. Press Windows Key + X and select Command Prompt (Admin) (it might be replaced by powershell and if so, type cmd in the search and run it as an administrator) Then, type the following command:

sfc /scannow

If that command didn't work, then try these:

DISM.exe /online /cleanup-image /scanhealth
DISM.exe /online /cleanup-image /restorehealth

If the error is still occurring, do the following:

NOTE: This step is the one you should be careful around cause editing the registry can cause more problems so follow this step carefully. Creating a backup is advised.

Press Windows Key + R and type regedit Navigate to HKEY_CURRENT_USER / Software / Microsoft / Windows / CurrentVersion / Policies / Explorer. If the key NoLowDiskSpaceChecks doesn't exist, then right-click to create a new DWORD value with that name. Then double click on the created value and type 1. Press OK and exit REGEDIT.

Good luck!

  • I have seen this answer before on Ms community.It's nearly a copy and past.Against my better judgement I tried your suggestions.Off course without any results, because all these suggestions are not really relevant to the problem.Those all have to do with integrity of certain system/install files.The service is working fine.Actually I have a second pool on the same machine that is giving me the correct numbers.I have the feeling you are just throwing some generic ideas towards the problem I advice everybody strongly against these not relevant suggestionsDon't loose time like me
    – Mumblic
    Commented May 13, 2020 at 13:39
  • Also changing the registry does not solve the problem. It's like putting a sticker over the "check engine" light in your car! Chkdsk returned zero errors. (BTW who is 'us', which group are you representing?)
    – Mumblic
    Commented May 13, 2020 at 13:44
  • I am just trying to help you and, if you didn't got your answer, why don't you post a thread on answers.microsoft.com/en-us Commented May 13, 2020 at 15:15
  • Here is a link to an thread and maybe fix it for you: social.technet.microsoft.com/Forums/exchange/en-US/… Also, did you actually tried doing a disk cleanup just in case? Commented May 13, 2020 at 15:23
  • I will try to explain it kindly:You write an answer when you fully understand the problem and when you have concrete answer.This is not a place were you can express suggestions, ideas, try this or that's.There are many other forums for that:like for example MS Answers.Seldom do I find truly answered question over there, even if they have an "answered" thick mark.That's why you can't copy and paste from over there Especially when the person that asked the question clearly stated it did not solve his problem!You are not helping anybody by suggesting things that make people lose time
    – Mumblic
    Commented May 13, 2020 at 16:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .