3

I'm using Lenovo Thinkpad E480 (i5-8250U), Windows 10 64bit. Recently, I started having a lot of video calls (via Zoom, Skype, etc.), and strangely, my camera goes off after half an hour of conversation. The led light next to the camera still light but the video is freeze.

Even after the call ends, the camera takes a long time to get back to normal. The solution I use now - I restart my computer and then allow myself another half hour of camera use, of course, it's a patch and no real solution.

What do you suggest to solve this issue?

1
  • Adding for posterity that I encountered this issue as well on my Lenovo Thinkpad (Windows 10, 64-bit) after approximately 30 minutes on Zoom calls.
    – Mathews24
    Oct 11 '20 at 18:33
1

Camera issues can be caused by a variety of problems. However, doing a little investigation on the ThinkPad in particular, I found a couple of options that could be applicable to your situation:

  1. Simply remove and reinstall the driver for the camera. You'll need to go into the Device Manager utility, find the camera, right-click and choose "Uninstall device", making sure you check the box that says "remove software" when prompted. Then choose "Scan for hardware changes" in the "Action" menu. This should rediscover the camera and reinstall the drivers.
  2. Disable "FrameServerMode" in the registry. This is somewhat more advanced, and only addresses a very specific scenario. Using regedit, you will need to find the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Media Foundation\Platform key in the registry, add a DWORD value named EnableFrameServerMode, leaving it set to the default value of 0. If you are running 64-bit OS, you will also need to do the same for the HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows Media Foundation\Platform key. You can find more details about this particular problem here.

Whether either of these will address your specific scenario, I can't say for sure. These kinds of problems are very difficult to diagnose without having physical access to the computer in question.

If neither of the above help, you can also check some settings in the Power Options (go to "Control Panel\Hardware and Sound\Power Options" in the Control Panel, click "Change plan settings", click "Change advanced power settings"). Look at these, if they are available:

USB settings

and

PCI Express settings

You can try setting those to "Disabled" and "Off", respectively, in case the camera is turning off as a result of power management issues.

1
  • The first option works for me.
    – Yanirmr
    May 14 '20 at 9:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.