0

I have downloaded debian iso in sub, then did

$ sudo dd bs=4M if=/Downloads/firmware-10.4.0-i386-DVD-1.iso of=/dev/sdb status=progress && sync 

But the iso has saved in partition, instead of device itself: $lsblk:

sdb      8:16   1  14.4G  0 disk 
├─sdb1   8:17   1   3.7G  0 part /media/user/Debian 10.4.0 i386 1
└─sdb2   8:18   1   2.2M  0 part 

And from here Why does 'dd' not work for creating bootable USB? is mentioned, i cannot boot from partition. But from the command above, as seen, I have specified device /dev/sdb and not partition /dev/sdb*, so should I now try to dd again? or is here possibility to boot from partition? But in boot menu in start, there is only to boot from other devices such as /dev/sdc and I do do not see possibility to boot from /dev/sdb1 which now contains the iso, so how to boot the iso and installation?

1

You're misinterpreting the output of lsblk.

The file you've downloaded and written is a disk image containing two partitions. By writing the image to disk, you've created a partition table with these partitions. (That's also the reason why writing to a partition doesn't work: partitions can't be nested.) This is the intended result.

Now I don't know what "boot menu" you're looking at, but apparently it's using Linux naming conventions (/dev/sdc etc.), so I'm guessing it's GRUB. That's already too late, your UEFI (motherboard's firmware, also incorrectly called BIOS - these are not used anymore) uses GRUB as its default bootloader. You have to interrupt the normal boot and select partition there. This is usually done by pressing some button during boot. You could also press c in GRUB, enter fwsetup command and press Enter - this should take you to UEFI setup which will let you reorder bootloaders.

| improve this answer | |
  • Maybe his i386 based computer, even today, still uses a BIOS?? Haven't seen one with a UEFI firmware. ;-) – bey0nd May 14 at 16:33
  • The problem is from UEFI setup (called "InsydeH20 setup utility"), in boot section, there are only option to change boot mode and secure boot, no option to change or select bootloader (There is also boot priority - I have windows before), but do not know how to select iso from the usb. Any idea? – Herdsman May 14 at 17:00
  • I needed to switch from UEFI to legacy : ifixit.com/Answers/View/110162/…, but is seems hacky for me – Herdsman May 14 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.