2

I recently attempted to install ubuntu onto a removable USB drive. Eventually, I wanted to replace the ubuntu version with another, but the problem is that, besides for the 3.7gb of "free space" I can mount the new boot ISO onto, there is about 6mb of some "CDFS" boot file system, which is preventing any other boot system from being booted from.

So basically, I need to delete this CDFS voluem.

Running diskpart, I do the following commands:

list volume

to which I see volume 1 is the CDFS filesystem I am trying to delete, so then

select volume 1

so far so good

but then:

delete volume

is where the trouble is, because I get the following output:

DiskPart cannot delete volumes on removable media.

I've tried looking this up but couldn't find any conclusive articles, and for sure not on the stackexchange, so:

How do I remove a CDFS filesystem from a removable USB drive, using windows [vista or 7]?

4
  • Please specify the Windows version you’re using. – Daniel B May 18 '20 at 10:34
  • @DanielB it says in the question, vista or 7 – bluejayke May 18 '20 at 13:20
  • My best bet is try to use Partition Wizard first for managing non-windows (FAT*/NTFS) partition. Free version should've enough to delete/recreate partition. – fa wildchild May 18 '20 at 15:19
  • @fawildchild I tried that and tried removing all partitions other ways but it still shows up – bluejayke May 25 '20 at 3:23
3
+25

You can try diskpart on windows (as admin)

  1. list disk
  2. select disk n
  3. clean

Now you have a blank USB-Stick that you can format in the explorer

1
  • did that, cdfs is still there – bluejayke May 18 '20 at 13:20
3

All Windows versions earlier than Windows 10 1703 will refuse to manage partitions on removable devices (USB drives, card readers, …). This applies to diskpart as well as Disk Management, because both use the same underlying operation system services.

The only action you could use is clean in diskpart, followed by create partition primary. However, Windows appears to have problems dealing with remainders of the ISO image in some areas of the disk.

It is simply not possible to accomplish what you want with these operating systems. You can use third-party software (partition managers) on top, though.

Still, I’d recommend using a GParted Live Linux to do this. It’s easy to use and free.

Update: Further experimentation has revealed that Rufus can also do the job. Just make sure “Boot selection” is set to not bootable and you’re good to go. Rufus is also a great way to put ISO images on USB drives while keeping them writable.

3
  • did clean on diskpart, but didnt remove cdfs. What 3rd party software would be OK? Also, how could I use live linux on windows, without booting from linux? Because the problem is I have no other drive to boot from, only 1 USB drive, so in order to use a live linux, I would need to install it on a USB drive, but that is what I'm trying to do in the first place, but am unable to do so – bluejayke May 18 '20 at 13:22
  • I updated my answer after struggling even with an up-to-date Windows 10. – Daniel B May 18 '20 at 13:27
  • @bluejayke Did you have the time to try Rufus yet? – Daniel B May 21 '20 at 15:04
1

I always use a Kali live OS on any computer and use the dd command line tool to delete the partitions on the usb drive. Word of caution is to make sure you select the correct drive.

dd if=/dev/zero of=/dev/sda bs=512 count=1 conv=notrunc
1
  • Is there a way to do this with windows though? – bluejayke May 17 '20 at 4:57
1

Negative answer: You cannot add the CDFS partition space to the usable hard disk, for the simple reason that it is not on the disk.

This drive contains a hard disk that you may access freely, but the CDFS file system is on a separate partition that is actually found on a separate write-protected NAND Chip.

The most you can do is reprogram the JMS539 Bridge controller on the drive to bridge the connection directly to the hard drive and not go through the NAND Chip. This will either remove the CDFS partition leaving only the hard disk, or it will brick the drive totally (especially if your drive has another model of Bridge controller).

If you wish to live dangerously, see this answer on the post How to delete a CDFS partition on a hard drive. It refers to software from an article that still exists only on the Wayback Machine where the software can still be downloaded. I don't take responsibility for anything that will happen if it's used.


If the USB in question is an SMI device, it may be possible to format it by the program sm32Xtest.exe.

For tutorial, see the article How to Format the Apple USB Restore stick (the utility can be used for more types of devices).

Or watch on YouTube the video
Delete USB Virtual CD Drive, Delete CDFS Partition & Make USB Virtual CD Drive + Autorun.

9
  • did that, formatted multiple times, cdfs is still there – bluejayke May 18 '20 at 13:21
  • You are right, and it will stay there for eternity, as I explain above. Getting another drive is perhaps the best solution. – harrymc May 18 '20 at 15:01
  • another drive cost money, and it wasn't there before I had installed this other ubuntu ISO on it, all I want to do is undo what i have already done so I dont have to waste a bunch of money on the USB drive i already have – bluejayke May 18 '20 at 22:44
  • OP said they put an Ubuntu image on a regular USB flash drive. Not sure how you arrive at the conclusion that this is about CD-ROM simulation with a specific SATA-USB bridge chip. – Daniel B May 19 '20 at 7:54
  • It seems strange for the CDFS to appear because of something that was written to the disk, unless the Bridge controller was somehow reprogrammed. I would think that re-format would remove anything that could have ever been written to the disk. Your experience proves to me that the CDFS is not in that space. It's more likely it was always there but was never before a problem. Even if the Bridge controller can be reprogrammed to hide the CDFS, this is then unlikely to gain more space, and will just change the nature of the device. – harrymc May 19 '20 at 8:02
0

'Most likely the reason they did this was to prevent overwriting their software from the flash drive.' This particular topic should be similar and could fix your problems. https://superuser.com/a/470663/735050 (e.g. If the CLEAN command doesn't work, try RECOVER.)

If that build-in feature in Windows doesn't work then I am afraid you need to refer to external software in Windows like in https://www.youtube.com/watch?v=XbQT2mr3AS8.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.