8

I'm trying to upgrade my Ubuntu distro from 18.04 LTS to 20.04 LTS and I get this error message while it's calculating data,

An unresolvable problem occurred while calculating the upgrade.

This was caused by:

  • Upgrading to a pre-release version of Ubuntu This is most likely a transient problem, please try again later. If none of this applies, then please report this bug using the command 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal. If you want to investigate this yourself the log files in '/var/log/dist-upgrade' will contain details about the upgrade. Specifically, look at 'main.log' and 'apt.log'.

The output from the command grep Broken /var/log/dist-upgrade/apt.log is,

Broken dpkg:amd64 Breaks on libapt-pkg5.0:amd64 < 1.6.12 @ii mK > (< 1.7~b)
Broken libqt5core5a:amd64 Breaks on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK > (< 4:4.8.7+dfsg-20~)
Broken libuno-sal3:amd64 Breaks on uno-libs3:amd64 < 6.0.7-0ubuntu0.18.04.10 @ii mK >
Broken libqtgui4:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
Broken python2:amd64 Breaks on python:amd64 < 2.7.15~rc1-1 @ii mK > (< 2.7.15-2)
Broken libqt4-declarative:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
Broken qt-at-spi:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.8~)
Broken libpyside-py3-1.2:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.7.0)
Broken libpyside1.2:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.7.0)
Broken python2-minimal:amd64 Breaks on python-minimal:amd64 < 2.7.15~rc1-1 @ii mK > (< 2.7.15-2)
Broken libpython2-stdlib:amd64 Breaks on libpython-stdlib:amd64 < 2.7.15~rc1-1 @ii mK > (< 2.7.15-2)
Broken libqtdbus4:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
Broken python3-pyside.qtcore:amd64 Depends on libpyside-py3-1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
Broken python-pyside.qtcore:amd64 Depends on libpyside1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
Broken gnome-settings-daemon-common:amd64 Breaks on gnome-settings-daemon-schemas:amd64 < 3.28.1-0ubuntu1.3 @ii mK > (< 3.30.1.2-2~)
Broken libqt4-network:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
Broken python3-pyside.qtgui:amd64 Depends on libpyside-py3-1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
Broken python-pyside.qtgui:amd64 Depends on libpyside1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
Broken libqt4-xml:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
Broken libqt4-sql:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
Broken python-gi:amd64 Depends on python2:amd64 < none | 2.7.17-2ubuntu4 @un uH > (< 2.8)
Broken libsensors-config:amd64 Conflicts on libsensors4:amd64 < 1:3.4.0-4 @ii mK >
Broken libqt4-dbus:amd64 Depends on libqtdbus4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
Broken g++:amd64 Depends on g++-9:amd64 < none | 9.3.0-10ubuntu2 @un uH > (>= 9.3.0-3~)
Broken libqt4-script:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
Broken libqt4-sql-sqlite:amd64 Depends on libqt4-sql:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
Broken libqt4-sql-mysql:amd64 Depends on libqt4-sql:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
Broken python-six:amd64 Depends on python2:any:any < none @un H > (< 2.8)
Broken libhdf5-103:amd64 Depends on libgfortran5:amd64 < none | 10-20200411-0ubuntu1 @un uH > (>= 8)
Broken libqt4-xmlpatterns:amd64 Depends on libqt4-network:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
Broken python-enum34:amd64 Depends on python2:any:any < none @un H > (< 2.8)
Broken liblapack3:amd64 Depends on libgfortran5:amd64 < none | 10-20200411-0ubuntu1 @un uH > (>= 8)
Broken slurm-wlm-basic-plugins:amd64 Depends on libhdf5-103:amd64 < none | 1.10.4+repack-11ubuntu1 @un uH >
Broken libpython2-dev:amd64 Breaks on libpython-dev:amd64 < 2.7.15~rc1-1 @ii mK > (< 2.7.15-2)
Broken libqt4-opengl:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
Broken libphonon4:amd64 Depends on libqt4-dbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.8.1)
Broken python-all:amd64 Depends on python2:amd64 < none | 2.7.17-2ubuntu4 @un uH > (= 2.7.17-2ubuntu4)
Broken python-pkg-resources:amd64 Depends on python2:any:any < none @un H > (< 2.8)
Broken python-ipaddress:amd64 Depends on python2:any:any < none @un H > (< 2.8)
Broken python2-dev:amd64 Depends on python2:amd64 < none | 2.7.17-2ubuntu4 @un uH > (= 2.7.17-2ubuntu4)
Broken slurm-client:amd64 Depends on libhdf5-103:amd64 < none | 1.10.4+repack-11ubuntu1 @un uH >
Broken python-cairo:amd64 Depends on python2:amd64 < none | 2.7.17-2ubuntu4 @un uH > (< 2.8)
Broken libldb2:amd64 Breaks on libldb1:amd64 < 2:1.2.3-1ubuntu0.1 @ii mK > (< 2:2~)
Broken python-crypto:amd64 Depends on python2:amd64 < none | 2.7.17-2ubuntu4 @un uH > (< 2.8)
Broken libtinyxml2-6a:amd64 Conflicts on libtinyxml2-6:amd64 < 6.0.0+dfsg-1 @ii mK >
Broken qdbus:amd64 Depends on libqt4-xml:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
Broken python-all-dev:amd64 Depends on python2:amd64 < none | 2.7.17-2ubuntu4 @un uH > (= 2.7.17-2ubuntu4)
Broken python-xdg:amd64 Depends on python2:any:any < none @un H > (< 2.8)
Broken python-keyring:amd64 Depends on python2:any:any < none @un H > (< 2.8)
Broken python-dbus:amd64 Depends on python2:amd64 < none | 2.7.17-2ubuntu4 @un uH > (< 2.8)
Broken python-entrypoints:amd64 Depends on python2:any:any < none @un H > (< 2.8)
Broken python3-pyside.qtnetwork:amd64 Depends on libpyside-py3-1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
Broken libatlas3-base:amd64 Depends on libgfortran5:amd64 < none | 10-20200411-0ubuntu1 @un uH > (>= 8)
Broken python-setuptools:amd64 Depends on python-pkg-resources:amd64 < 39.0.1-2 | 44.0.0-2 @ii umH > (= 44.0.0-2)
Broken python-pyside.qtnetwork:amd64 Depends on libpyside1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
Broken python-cryptography:amd64 Depends on python2:amd64 < none | 2.7.17-2ubuntu4 @un uH > (< 2.8)
Broken libqt4-svg:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
Broken python-cffi-backend:amd64 Depends on python2:amd64 < none | 2.7.17-2ubuntu4 @un uH > (< 2.8)
Broken libqca2:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.8.0)
Broken python-asn1crypto:amd64 Depends on python2:any:any < none @un H > (< 2.8)
Broken libqca2-plugins:amd64 Depends on libqca2:amd64 < 2.1.3-2ubuntu2 @ii mR > (= 2.1.3-2ubuntu2)
Broken libqt4-help:amd64 Depends on libqt4-network:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
Broken phonon:amd64 Depends on libphonon4:amd64 < 4:4.10.0-2 @ii mR > (>= 4:4.10.0-2)
Broken python-gi-cairo:amd64 Depends on python-gi:amd64 < 3.26.1-2ubuntu1 | 3.36.0-1 @ii umH > (= 3.36.0-1)
Broken python-idna:amd64 Depends on python2:any:any < none @un H > (< 2.8)
Broken libqtwebkit4:amd64 Depends on libqt4-network:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.7.0~beta1)
Broken libatlas-base-dev:amd64 Depends on libatlas3-base:amd64 < 3.10.3-5 | 3.10.3-8ubuntu7 @ii umH > (= 3.10.3-8ubuntu7)
Broken python-psutil:amd64 Depends on python2:amd64 < none | 2.7.17-2ubuntu4 @un uH > (< 2.8)
Broken python-pyside.qtxml:amd64 Depends on libpyside1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
Broken python-configparser:amd64 Depends on python2:any:any < none @un H > (< 2.8)
Broken libqt4-scripttools:amd64 Depends on libqt4-script:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
Broken fwupdate:amd64 Breaks on fwupdate-signed:amd64 < 12-7~ubuntu18.04.3 @ii mK >
Broken fwupdate:amd64 Breaks on libfwup1:amd64 < 12-3bionic2 @ii mK > (< 12-5)
Broken libqt4-test:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
Broken python3-pyside.qtxml:amd64 Depends on libpyside-py3-1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
Broken slurm-wlm-torque:amd64 Depends on slurm-client:amd64 < 17.11.2-1build1 | 19.05.5-1 @ii umH > (>= 19.05.5-1)
Broken gfortran:amd64 Depends on gfortran-9:amd64 < none | 9.3.0-10ubuntu2 @un uH > (>= 9.3.0-3~)
Broken liblapack-dev:amd64 Depends on liblapack3:amd64 < 3.7.1-4ubuntu1 | 3.9.0-1build1 @ii umH > (= 3.9.0-1build1)
Broken python-pyside.qtscript:amd64 Depends on libpyside1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
Broken libqxt-core0:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.8.0)
Broken python3-pyside.qtscript:amd64 Depends on libpyside-py3-1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
Broken python-pyside.qthelp:amd64 Depends on libpyside1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
Broken libfreeipmi16:amd64 Depends on freeipmi-common:amd64 < 1.4.11-1.1ubuntu4.1 -> 1.6.4-3ubuntu1 @ii umU > (= 1.4.11-1.1ubuntu4.1)
Broken python-pyside.qtsvg:amd64 Depends on libpyside1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
Broken libpolkit-qt-1-1:amd64 Depends on libqt4-dbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.5.3)
Broken python-pyside.phonon:amd64 Depends on libpyside1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
Broken python3-pyside.qthelp:amd64 Depends on libpyside-py3-1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
Broken python-pyside.qtwebkit:amd64 Depends on libpyside1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
Broken libedata-book-1.2-25:amd64 Depends on libebackend-1.2-10:amd64 < 3.28.5-0ubuntu0.18.04.2 -> 3.36.1-2 @ii umU > (= 3.28.5-0ubuntu0.18.04.2)
Broken phonon-backend-gstreamer:amd64 Depends on phonon-backend-gstreamer-common:amd64 < 4:4.9.0-1 -> 4:4.10.0-1build1 @ii umU > (= 4:4.9.0-1)
Broken python3-pyside.qtsvg:amd64 Depends on libpyside-py3-1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
Broken policykit-1-fingerprint-gui:amd64 Depends on libpolkit-qt-1-1:amd64 < 0.112.0-5 @ii mR > (>= 0.99.0)
Broken python3-pyside.qtsql:amd64 Depends on libpyside-py3-1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
Broken python3-pyside.qtopengl:amd64 Depends on libpyside-py3-1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
Broken python-pyside.qtdeclarative:amd64 Depends on libpyside1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
Broken python3-pyside.qtdeclarative:amd64 Depends on libpyside-py3-1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
Broken python-pyside.qtsql:amd64 Depends on libpyside1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
Broken libqjson0:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.7.0~beta1)
Broken python-pyside.qttest:amd64 Depends on libpyside1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
Broken python3-pyside.phonon:amd64 Depends on libpyside-py3-1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
Broken python3-pyside.qttest:amd64 Depends on libpyside-py3-1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
Broken python-pyside.qtopengl:amd64 Depends on libpyside1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
Broken fingerprint-gui:amd64 Depends on libqca2:amd64 < 2.1.3-2ubuntu2 @ii mR > (>= 2.0.2)
Broken libpango1.0-0:amd64 Depends on libpango-1.0-0:amd64 < 1.40.14-1ubuntu0.1 -> 1.44.7-2ubuntu4 @ii umU > (= 1.40.14-1ubuntu0.1)
Broken python-pyside.qtuitools:amd64 Depends on libpyside1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
Broken python3-pyside.qtuitools:amd64 Depends on libpyside-py3-1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
Broken python3-pyside.qtwebkit:amd64 Depends on libpyside-py3-1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
Broken python-pip:amd64 Depends on python-pip-whl:amd64 < 9.0.1-2.3~ubuntu1.18.04.1 -> 20.0.2-5ubuntu1 @ii umU > (= 9.0.1-2.3~ubuntu1.18.04.1)
Broken libmygpo-qt1:amd64 Depends on libqjson0:amd64 < 0.8.1-3 @ii mR > (>= 0.7.1)
Broken libcupsppdc1:amd64 Depends on libcups2:amd64 < 2.2.7-1ubuntu2.8 -> 2.3.1-9ubuntu1.1 @ii umU > (= 2.2.7-1ubuntu2.8)
Broken libedata-cal-1.2-28:amd64 Depends on libebackend-1.2-10:amd64 < 3.28.5-0ubuntu0.18.04.2 -> 3.36.1-2 @ii umU > (= 3.28.5-0ubuntu0.18.04.2)
Broken libept1.5.0:amd64 Depends on libapt-pkg5.0:amd64 < 1.6.12 @ii mR > (>= 1.1~exp9)
Broken libipmimonitoring5a:amd64 Depends on libfreeipmi16:amd64 < 1.4.11-1.1ubuntu4.1 @ii mR > (>= 1.4.4)
Broken libcupsmime1:amd64 Depends on libcups2:amd64 < 2.2.7-1ubuntu2.8 -> 2.3.1-9ubuntu1.1 @ii umU > (= 2.2.7-1ubuntu2.8)
Broken libpolkit-backend-1-0:amd64 Depends on libpolkit-gobject-1-0:amd64 < 0.105-20ubuntu0.18.04.5 -> 0.105-26ubuntu1 @ii umU > (= 0.105-20ubuntu0.18.04.5)
Broken libqxt-gui0:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.8.0~)
Broken libsnmp30:amd64 Depends on libsensors4:amd64 < 1:3.4.0-4 @ii mR > (>= 1:3.0.0)
Broken python3-pyside:amd64 Depends on python3-pyside.phonon:amd64 < 1.2.2+source1-3 @ii mR > (>= 1.2.2+source1-3)
Broken libcupscgi1:amd64 Depends on libcups2:amd64 < 2.2.7-1ubuntu2.8 -> 2.3.1-9ubuntu1.1 @ii umU > (= 2.2.7-1ubuntu2.8)
Broken python-pyside:amd64 Depends on python-pyside.phonon:amd64 < 1.2.2+source1-3 @ii mR > (>= 1.2.2+source1-3)
Broken libapt-inst2.0:amd64 Depends on libapt-pkg5.0:amd64 < 1.6.12 @ii mR > (>= 1.1~exp9)
Broken libebook-1.2-19:amd64 Depends on libedata-book-1.2-25:amd64 < 3.28.5-0ubuntu0.18.04.2 @ii mR > (= 3.28.5-0ubuntu0.18.04.2)
Broken liblastfm1:amd64 Depends on libqt4-dbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.5.3)
Broken python-dev:amd64 Depends on libpython-dev:amd64 < 2.7.15~rc1-1 @ii mR > (= 2.7.15~rc1-1)
Broken libgirepository-1.0-1:amd64 Breaks on python-gi:amd64 < 3.26.1-2ubuntu1 | 3.36.0-1 @ii umH > (< 3.34.0-4~)
Broken build-essential:amd64 Depends on g++:amd64 < 4:7.4.0-1ubuntu2.3 | 4:9.3.0-1ubuntu2 @ii umH > (>= 4:9.2)
Broken python-gi:amd64 Depends on python2:amd64 < none | 2.7.17-2ubuntu4 @un uH > (< 2.8)
Broken slurm-wlm-basic-plugins:amd64 Depends on libipmimonitoring5a:amd64 < 1.4.11-1.1ubuntu4.1 @ii mR > (>= 1.1.5)
Broken libipmimonitoring5a:amd64 Depends on libfreeipmi16:amd64 < 1.4.11-1.1ubuntu4.1 @ii mR > (>= 1.4.4)
Broken libgirepository-1.0-1:amd64 Breaks on python-gi:amd64 < 3.26.1-2ubuntu1 | 3.36.0-1 @ii umH > (< 3.34.0-4~)
Broken python-gi:amd64 Depends on python2:amd64 < none | 2.7.17-2ubuntu4 @un uH > (< 2.8)
Broken slurm-wlm-basic-plugins:amd64 Depends on libipmimonitoring5a:amd64 < 1.4.11-1.1ubuntu4.1 @ii mR > (>= 1.1.5)
Broken libipmimonitoring5a:amd64 Depends on libfreeipmi16:amd64 < 1.4.11-1.1ubuntu4.1 @ii mR > (>= 1.4.4)
Broken libipmimonitoring5a:amd64 Depends on freeipmi-common:amd64 < 1.4.11-1.1ubuntu4.1 -> 1.6.4-3ubuntu1 @ii umU > (= 1.4.11-1.1ubuntu4.1)
Broken libgirepository-1.0-1:amd64 Breaks on python-gi:amd64 < 3.26.1-2ubuntu1 | 3.36.0-1 @ii umH > (< 3.34.0-4~)
Broken python-gi:amd64 Depends on python2:amd64 < none | 2.7.17-2ubuntu4 @un uH > (< 2.8)
Broken libfreeipmi16:amd64 Depends on freeipmi-common:amd64 < 1.4.11-1.1ubuntu4.1 -> 1.6.4-3ubuntu1 @ii umU > (= 1.4.11-1.1ubuntu4.1)
Broken libipmimonitoring5a:amd64 Depends on libfreeipmi16:amd64 < 1.4.11-1.1ubuntu4.1 @ii mR > (>= 1.4.4)
Broken libgirepository-1.0-1:amd64 Breaks on python-gi:amd64 < 3.26.1-2ubuntu1 | 3.36.0-1 @ii umH > (< 3.34.0-4~)
Broken python-gi:amd64 Depends on python2:amd64 < none | 2.7.17-2ubuntu4 @un uH > (< 2.8)
Broken slurm-wlm-basic-plugins:amd64 Depends on libipmimonitoring5a:amd64 < 1.4.11-1.1ubuntu4.1 @ii mR > (>= 1.1.5)
Broken slurm-client:amd64 Depends on slurm-wlm-basic-plugins:amd64 < 17.11.2-1build1 | 19.05.5-1 @ii umR > (= 17.11.2-1build1)
Broken slurm-wlm-torque:amd64 Depends on slurm-client:amd64 < 17.11.2-1build1 | 19.05.5-1 @ii umR > (>= 17.11.2-1build1)
Broken libgirepository-1.0-1:amd64 Breaks on python-gi:amd64 < 3.26.1-2ubuntu1 | 3.36.0-1 @ii umH > (< 3.34.0-4~)
Broken python-gi:amd64 Depends on python2:amd64 < none | 2.7.17-2ubuntu4 @un uH > (< 2.8)
Broken libgirepository-1.0-1:amd64 Breaks on python-gi:amd64 < 3.26.1-2ubuntu1 | 3.36.0-1 @ii umH > (< 3.34.0-4~)
Broken python-gi:amd64 Depends on python2:amd64 < none | 2.7.17-2ubuntu4 @un uH > (< 2.8)
Broken libgirepository-1.0-1:amd64 Breaks on python-gi:amd64 < 3.26.1-2ubuntu1 | 3.36.0-1 @ii umH > (< 3.34.0-4~)
Broken python-gi:amd64 Depends on python2:amd64 < none | 2.7.17-2ubuntu4 @un uH > (< 2.8)
Broken libgirepository-1.0-1:amd64 Breaks on python-gi:amd64 < 3.26.1-2ubuntu1 | 3.36.0-1 @ii umH > (< 3.34.0-4~)
Broken python-gi:amd64 Depends on python2:amd64 < none | 2.7.17-2ubuntu4 @un uH > (< 2.8)
Broken libgirepository-1.0-1:amd64 Breaks on python-gi:amd64 < 3.26.1-2ubuntu1 | 3.36.0-1 @ii umH > (< 3.34.0-4~)
Broken python-gi:amd64 Depends on python2:amd64 < none | 2.7.17-2ubuntu4 @un uH > (< 2.8)

and the main.log file contains,

2020-05-14 01:35:01,901 INFO Using config files '['./DistUpgrade.cfg.bionic']'
2020-05-14 01:35:01,901 INFO uname information: 'Linux Inspiron-5570 4.15.0-99-generic #100-Ubuntu SMP Wed Apr 22 20:32:56 UTC 2020 x86_64'
2020-05-14 01:35:02,351 INFO apt version: '1.6.12'
2020-05-14 01:35:02,352 INFO python version: '3.6.9 (default, Apr 18 2020, 01:56:04) 
[GCC 8.4.0]'
2020-05-14 01:35:02,355 INFO release-upgrader version '20.04.19' started
2020-05-14 01:35:02,418 INFO locale: 'en_US' 'UTF-8'
2020-05-14 01:35:02,653 DEBUG Using 'DistUpgradeViewGtk3' view
2020-05-14 01:35:02,700 DEBUG enable dpkg --force-overwrite
2020-05-14 01:35:02,719 DEBUG creating statefile: '/var/log/dist-upgrade/apt-clone_system_state.tar.gz'
2020-05-14 01:35:05,705 DEBUG lsb-release: 'bionic'
2020-05-14 01:35:05,705 DEBUG _pythonSymlinkCheck run
2020-05-14 01:35:05,728 DEBUG openCache()
2020-05-14 01:35:05,729 DEBUG quirks: running PreCacheOpen
2020-05-14 01:35:05,729 DEBUG running Quirks.PreCacheOpen
2020-05-14 01:35:06,368 DEBUG /openCache(), new cache size 97092
2020-05-14 01:35:06,371 DEBUG need_server_mode(): run in 'desktop' mode, (because of pkg 'ubuntu-desktop')
2020-05-14 01:35:06,371 DEBUG checkViewDepends()
2020-05-14 01:35:06,372 DEBUG running doUpdate() (showErrors=False)
2020-05-14 01:35:09,086 DEBUG openCache()
2020-05-14 01:35:09,771 DEBUG /openCache(), new cache size 97092
2020-05-14 01:35:09,772 DEBUG doPostInitialUpdate
2020-05-14 01:35:09,772 DEBUG quirks: running focalPostInitialUpdate
2020-05-14 01:35:09,772 DEBUG running Quirks.focalPostInitialUpdate
2020-05-14 01:35:12,956 DEBUG Snap core18 is installed
2020-05-14 01:35:13,222 DEBUG Snap gnome-3-34-1804 is installed
2020-05-14 01:35:13,224 DEBUG Snap gnome-3-34-1804 is not tracking the release channel
2020-05-14 01:35:13,513 DEBUG Snap gtk-common-themes is installed
2020-05-14 01:35:14,022 DEBUG Snap gnome-3-28-1804 is installed
2020-05-14 01:35:14,023 DEBUG Snap gnome-3-28-1804 is not tracking the release channel
2020-05-14 01:35:14,621 DEBUG Snap gnome-characters is installed
2020-05-14 01:35:14,928 DEBUG Snap gnome-logs is installed
2020-05-14 01:35:17,173 DEBUG MetaPkgs: ubuntu-desktop
2020-05-14 01:35:19,334 DEBUG Foreign: 
2020-05-14 01:35:19,334 DEBUG Obsolete: anydesk code cpp-9 filemanager-actions filemanager-actions-nautilus-extension fingerprint-gui flash-plugin flat-remix-gnome gcc-10-base gcc-10-base:i386 gcc-9 gcc-9-base gcc-9-base:i386 google-chrome-stable grub-customizer indicator-netspeed-unity libbsapi libgcc-9-dev libgcc-s1 libgcc-s1:i386 policykit-1-fingerprint-gui skypeforlinux spotify-client sublime-text teams timeshift uniform-icons wolframscript
2020-05-14 01:35:19,335 DEBUG updateSourcesList()
2020-05-14 01:35:25,637 DEBUG rewriteSourcesList() with mirror_check
2020-05-14 01:35:25,638 DEBUG ['ubuntu-minimal', 'ubuntu-standard']
2020-05-14 01:35:25,638 DEBUG Checking pkg: ubuntu-minimal
2020-05-14 01:35:25,643 DEBUG Checking pkg: ubuntu-standard
2020-05-14 01:35:25,647 DEBUG examining: 'deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse'
2020-05-14 01:35:25,648 DEBUG verifySourcesListEntry: deb http://archive.ubuntu.com/ubuntu focal main restricted universe multiverse
2020-05-14 01:35:25,648 DEBUG url_downloadable: http://archive.ubuntu.com/ubuntu/dists/focal/Release
2020-05-14 01:35:25,648 DEBUG s='http' n='archive.ubuntu.com' p='/ubuntu/dists/focal/Release' q='' f=''
2020-05-14 01:35:25,928 DEBUG entry 'deb http://archive.ubuntu.com/ubuntu focal main restricted universe multiverse' updated to new dist
2020-05-14 01:35:25,928 DEBUG examining: 'deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse'
2020-05-14 01:35:25,928 DEBUG entry 'deb http://archive.ubuntu.com/ubuntu focal-updates main restricted universe multiverse' updated to new dist
2020-05-14 01:35:25,929 DEBUG examining: 'deb http://archive.ubuntu.com/ubuntu bionic-security main restricted universe multiverse'
2020-05-14 01:35:25,929 DEBUG entry 'deb http://archive.ubuntu.com/ubuntu focal-security main restricted universe multiverse' updated to new dist
2020-05-14 01:35:25,934 DEBUG running doUpdate() (showErrors=True)
2020-05-14 01:36:28,983 DEBUG openCache()
2020-05-14 01:36:29,497 DEBUG /openCache(), new cache size 65466
2020-05-14 01:36:29,498 DEBUG need_server_mode(): run in 'desktop' mode, (because of pkg 'ubuntu-desktop')
2020-05-14 01:36:45,649 ERROR Dist-upgrade failed: 'E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.'
2020-05-14 01:36:45,671 DEBUG abort called
2020-05-14 01:36:45,680 DEBUG openCache()
2020-05-14 01:36:47,981 DEBUG /openCache(), new cache size 97092

I know there must be something wrong with my Python installations but I don't know how to fix it. My theory is that I hold packages that are different from the default Ubuntu 18.04 ones and the installer does not know what to do with them.

4

I had a very similar problem. main.log was identical, the problems listed in apt.log were different.

In my case the culprint seemd to be Qt4 together with Python. I solved my issue by removing these from my system:

sudo apt-get remove python-pyqt4 python-pyside python3-pyqt4

Id did not have python3-pyside installed so if you still have troubles after removing the above mentioned packages, you can chack if python3-pyside is present on your system.

Do not forget to do a apt-get autoremove at the end.

After that I was able to start do-release-upgrade without the error message.

4

As before you upgrade Ubuntu, you have to remove unnecessary and corrupted packages. I have resolved issue by following commands:

apt list --upgradable
sudo apt autoremove
sudo do-release-upgrade -d -f DistUpgradeViewGtk3
1
  • 1
    Thank you for the answer, but this didn't resolve the problem for me (same issue as the OP). Also, the third line of your suggestion is just showing the help, so it can be safely removed. Nov 29 '20 at 9:54
2

The problem is a well known bug and many people are affected by it:

https://bugs.launchpad.net/ubuntu/+source/llvm-toolchain-9/+bug/1886748

In my case I had only to remove libomp5 and libomp-dev. (As nothing depended on them, this was it.)

I had tried before to remove large parts of python, this didn't help and removes of course many packages.

1

In some cases it might be more than one package, I followed through these steps:

  1. Check on the file /var/log/dist-upgrade/apt.log for any broken package listed there

  2. Remove the package using apt sudo apt remove {broken package name}

  3. Run sudo apt autoremove to get ride of residual packages

  4. Run sudo do-release-upgrade again if it throws the error message below:

    Could not calculate the upgrade

    An unresolvable problem occurred while calculating the upgrade.

    This was likely caused by:

    • Unofficial software packages not provided by Ubuntu Please use the tool 'ppa-purge' from the ppa-purge package to remove software from a Launchpad PPA and try the upgrade again.

    If none of this applies, then please report this bug using the command 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal. If you want to investigate this yourself the log files in '/var/log/dist-upgrade' will contain details about the upgrade. Specifically, look at 'main.log' and 'apt.log'.

Repeat step 1 to 4

0

I agree with leviathan . I had the same problem, with different broken packages (a crazily long list). I am not very expert, and What I did was to just to remove the first entry. This caused a mess, including removing the do-release-upgrade. So, I fixed that issue with this command:

sudo apt install ubuntu-release-upgrader-core 

I then retried the upgrade, and it worked! So basically you have to look into the broken packages and remove them (python is the usual suspect. In my case it was somthing else, but as a side product it also removed python), although I have to say that if you are not expert you may end up with some problems (like it happened to me!)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.