0

VirtualBox version

6.1

virtualbox version pic

Installed Debian 10.4.0 on it.

From VirtualBox menu select Devices -> Insert Guest Additions CD Image. CD automatically ran but unable to locate the program. Why?

guest additions folder in virtualbox pic

will run application on debian pic

cause an alert can't install the program pic


Addition

After ran this by root user, it can be installed

sh /media/cdrom/VBoxLinuxAdditions.run

But there is an another problem, restart OS it shown:

VBoxClient: The parent session seems to be non-X11. Exiting...

select default GNOME on the login page

VBoxClient alert

If resize the window to full screen, it can't change size at all.

  • I haven't had that problem in some time (not sure why) but I used to have to mount the tools drive, copy the files from it to my home, extract as needed, mark as executable, and run with sudo dpkg -i , or I think they have some shell scripts you can run. good luck. – Frank Thomas May 16 '20 at 7:08
  • I found I can't run sudo with my user in the system. The problem maybe is also due to the file or folder permission. – rawmain May 16 '20 at 7:17
  • well, and it installs kernel drivers so root is definitely required. if you don;t have sudo, can you su root? – Frank Thomas May 16 '20 at 7:18
  • Oh, you saved me! I can run su root, and then I ran sh /media/cdrom/VBoxLinuxAdditions.run to install the program successfully! – rawmain May 16 '20 at 7:21
  • But if I run sh sudo, it said su: user sudo does not exist. It seems sudo user doesn't exist after I install the OS. – rawmain May 16 '20 at 7:22
0

Answering to your update:

VBoxClient: The parent session seems to be non-X11. Exiting...

Following the suggestion in this Reddit post, it seems a bug in VirtualBox Guest Additions 6.1.

The last Guest Additions from 6.0 (http://download.virtualbox.org/virtualbox/6.0.22/VBoxGuestAdditions_6.0.22.iso) should not be affected.

I can confirm the old Additions work on my setup:

  • Windows 10 host
  • Debian Stretch guest
  • VirtualBox 6.1.8
  • Guest Additions 6.0.22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.