0

Two Debian/testing machines with same version of Firefox but different GPU and X drivers.

On my father's machine, accessing this website gives the following error message in the Firefox console: "WebGL support for vertex shader samplers is required but not supported." I have verified with the developers' site that indeed the support appears to be missing. If I run the same tests on my computer, they pass. So far, nothing odd: lack of WebGL support. I have also tried Chromium (only locally) on his computer and it has the same issue.

Now for the fun part:

  • in front of his computer, running Firefox on my computer (ssh -X) but sending the output to his computer: this also works just fine.
  • in front of my computer, running Firefox on his computer but getting the X output to mine: works nicely.

Only one copy of Firefox running in all tests, profile created from scratch but same results with either his or my normal profile.

If the fault lies with some missing library on his machine, before the application sends the output to the X display, then having mine as remote display should make no difference: it should fail, yet it works. Conversely, if the fault lies with the X display and the GPU drivers, then my own Firefox displayed on his computer should fail as well, but it also works.

How can it be? I'd love to understand what's going on and then fix it.

EDIT: ran the same test with my laptop (no webgl support) and my desktop: in this case, remoting does not change the results; firefox from the laptop still fails the test when output is on desktop and viceversa the test passes.

0

Never mind: the remote / local tests are only confusing the issue, as later tests with my old laptop confirmed. If the hw is too old and lacks proper support, there is simply no way to enable webgl support. (Integrated Graphics Chipset: Intel(R) Pineview GM)

Firefox, "about:support" shows:

WebGL creation failed: 
* Refused to create native OpenGL context because of blacklist entry: FEATURE_FAILURE_OPENGL_1
* Exhausted GL driver options.
WebGL creation failed: 
* Refused to create WebGL2 context because of blacklist entry: FEATURE_FAILURE_OPENGL_1
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.