0

Running Windows 10:

Similar to Windows global shortcut hijacked by Opera but the CTRL+SHIFT+N keybinding is globally bound to open up, or activate and then raise, the Microsoft Outlook window. This conflicts with the Google Chrome keybinding for opening up an incognito window:

IMG:

I can override it using a AutoHotkey script using conditional logic that is active only when Google Chrome window is active, allowing the binding to do whatever it is predefined to do in other windows:

#NoEnv  ; Recommended for performance and compatibility with future AutoHotkey releases.
SendMode Input  ; Recommended for new scripts due to its superior speed and reliability.
SetWorkingDir %A_ScriptDir%  ; Ensures a consistent starting directory.

; Map CTRL+SHIFT+n to activate the Google Chrome window and pass it on, instead of allowing Windows to open up a new instance of Outlook:
; See also https://superuser.com/q/1552465/106977 
#IfWinActive ahk_exe chrome.exe
$^+n::
Send, !f{Enter}i
return

And I might be able to code that script to raise the Google Chrome Window and pass along the CTRL+SHIFT+N keybinding, but that smacks of overkill: Is the installation of Outlook commandeering that keybinding, or is some other application doing it?

How do I do that? Or is it really the case that Windows is doing this, and also not documenting it properly since that keybinding is not in the documentation at Keyboard shortcuts in Windows.

Update on 2020-05-18 06:57:00: The following process, when killed, allows the CTRL+SHIFT+n keybinding to be handled properly by the Google Chrome process (which now opens up an incognito window as expected). But it has disastrous consequences: The desktop disappears! :

explorer.exe 9760 DLL C:\Users\thatuser\AppData\Local\Microsoft\OneDrive\20.052.0311.0011\amd64\FileSyncShell64.dll

Update on 2020-05-18 07:06:39: I searched for OneDrive shortcuts (https://duckduckgo.com/?q=onedrive+%22ctrl%2Bshift%2Bn%22&ia=web) and found conflicting information for various versions of OneDrive, none of which state that CTRL+SHIFT+n should open up a new/pre-existent instance of Outlook:

https://support.office.com/en-us/article/keyboard-shortcuts-in-onenote-44b8b3f4-c274-4bcc-a089-e80fdcc87950?ocmsassetID=HA010386947&CorrelationId=132aca36-4c6c-43b4-a366-7a9cc350fc2f&ui=en-US&rs=en-US&ad=US https://support.office.com/en-us/article/Keyboard-shortcuts-in-OneDrive-app-for-Windows-10-fcdb66e5-fde6-4654-bbae-21a5e0d88a0b https://www.customguide.com/cheat-sheet/onedrive-for-business-quick-reference.pdf

Update on 2020-05-18 07:23:34: I uninstalled OneDrive, and that made the FileSyncShell64.dll no longer appear. I rebooted and retested, and CTRL+SHIFT+n still invokes Outlook. Now, given that I killed explorer.exe earlier, killing that did fix the problem, but that masked the real culprit which is yet to be found (explorer.exe is, as I recall, critical for all of Windows to function). Thus, killing off explorer.exe is not the solution. I also believe that uninstalling Outlook is a non-option because I need Outlook, I just don’t want this global hijacking of the CTRL+SHIFT+n shortcut.

  • I updated the question to include the hackaround AutoHotkey script that works. However, that is not the answer to what I'm looking for, which is to figure out what is hijacking the keybinding to cause it to be different from its default. And see also my comment for a non-solution. – bgoodr May 16 at 23:46
  • If I remember correctly the OneNote system-tray launcher grabs Ctrl-Shift-N for "new Note". That would look as a system-wide high-jack of the key-binding. – Tonny May 17 at 9:32
  • @Tonny You are on to something, or so I thought, and worked through disabling OneNote startup "things" using docs.microsoft.com/en-us/sysinternals/downloads/autoruns (which did not implicate OneNote). See superuser.com/questions/1552465/… where I found that some DLL inside OneDrive might to be the culprit. And see my Update on 2020-05-18 06:57:00 in my OP. – bgoodr May 18 at 14:02
  • Added Update on 2020-05-18 07:06:39 to search for any relationship between OneDrive and Outlook and came up empty. – bgoodr May 18 at 14:11
  • Added Update on 2020-05-18 07:23:34 for further failed experiments with uninstalling OneDrive. – bgoodr May 18 at 14:27
1

I do not think that MS Outlook uses Ctrl+Shift+N as a global shortcut. I see it documented as Create a note local command and it has no global action on my computer, but the shortcut is appropriately interpreted by any focused application, for example by browsers.

Just check your 3rd-party apps for potential handling of the shortcut.
Start exiting/killing your apps and processes until the behavior stops. This will point you to potential evil-doer.

Help: You can stop the apps in the following way.

  1. Exit all open standard applications.
  2. Exit all apps which have their icon in notification area (next to the clock) and can be exited.
  3. Using Process Explorer from Microsoft list all your running processes, display column Company Name (menu View > Select Columns...) and sort the list by that column.
  4. Now you can safely skip all Microsoft processes or processes from known company names. Focus on the rest. Properties window of each process shows field Path showing you where the EXE is located. This may also say a lot. If in doubt, try right-clicking the process and select Check VirusTotal (it should return 0 positives although some false flags may appear) and then maybe kill it.

One forgotten feature: check Properties window of all your shortcuts on Desktop and in Start menu, which are potentially opening Outlook. On Shortcut tab in their Properties window, they have Shortcut Key field. Make sure you did not fill Ctrl+Shift+N there in some shortcut!

| improve this answer | |
  • I confirmed with my system administrators that CTRL+SHIFT+n being mapped to invoking and/or re-activating Outlook is not normal. There apparently is no way to find out what is mapping that keybinding to Outlook (at least, the answer at superuser.com/a/765148/106977 is actually pointing to malware, as I have discovered the hard way). – bgoodr May 16 at 23:24
  • The problem of exiting/killing apps until the behavior stops is presuming there are apps that can be killed in that manner. How can a non-expert know which is safe to kill? – bgoodr May 16 at 23:25
  • See my OP: I added Update on 2020-05-18 06:57:00: So it turns out that "Now you can safely skip all Microsoft processes..." is not true. But killing explorer.exe is also not a solution of course. But it gives a hint that the thing that installed that DLL is/might-be the culprit. OneDrive? – bgoodr May 18 at 13:59
  • 1
    @bgoodr – Are you really sure that the shortcut was placed there by the Office installation? I would say no, because I never had the same issue when using Office 2013. Ctrl+Shift+N always worked flawlessly along with Office 2013 as I know from SnagIt screen capture tool, where I used to use it for built-in functionality similarly as you do in Chrome. There was no hijacking. – miroxlav May 23 at 15:36
  • 1
    @bgoodr – I would also say the same. There was a period also in my user life when I was setting these shortcuts, too (but via much less colliding **Ctrl+Alt+Shift**+letter). Later I switched to the AutoHotKey. I appreciate your fairness to admit this most likely reason. Also I appreciate your rarely-seen sportsmanship in marking the answer. And third, I appreciate level of detail found in your own helpful answer. – miroxlav May 24 at 8:18
1

The last paragraph of miroxlav's answer is the answer. The previous part was also very instrumental in eliminating other possible causes of this problem. I did not notice that last paragraph at the point that I wrote this answer. This answer, however, had a lot of detail that shows how to get to that shortcut definition, so I'm leaving this answer in, and marking miroxlav's answer as "the" answer.


I cross-posted to https://answers.microsoft.com, which provided the answer:

https://answers.microsoft.com/en-us/windows/forum/windows_10-desktop/ctrlshiftn-is-opening-microsoft-outlook-2013/c1be666a-dc50-4097-b828-449f7e75fa4d?messageId=00ad1b54-848b-4067-a60b-bb7735cfb810&tm=1590154202614

I rewrote their answer below, to avoid eventual link-rot, add a method to find the Outlook Properties dialog box for the case whereby you don't have a taskbar or desktop shortcut, and to add context for Google Chrome's handling of the CTRL+SHIFT+N shortcut. Also, the section there starting at:

In order to enable this combination for Google Chrome,...

is not correct in this case (Google Chrome already handles the shortcut by default, and by changing it globally might obviate launching incognito windows), so that section is not included here:


Check for the case where the CTRL+SHIFT+N shortcut is enabled in Properties of the Outlook launch shortcut icon, as follows:

  1. Right mouse click on the Outlook shortcut icon in the Taskbar or on the Desktop until you see the Outlook menu entry. You will see something like this: enter image description here
    1. If you don't have Outlook pinned to the Taskbar or a Outlook Desktop shortcut, you can still navigate to the Properties menu through the Start menu: enter image description here
  2. Right mouse click on the Outlook menu entry, and select Properties. You will see something like this:enter image description here
  3. If you see CTRL + Shift + N there, then that is the global shortcut that is opening up Outlook when CTRL+SHIFT+N is pressed, which results in preventing all other applications (such as Google Chrome in this case) from seeing and processing it for their purposes (e.g., for opening up an incognito window).
  4. Under Shortcut tab, you will see the “Shortcut key” field.
  5. Click inside the “Shortcut key” field, and press Backspace. The option should show “None”.
  6. Click on OK.
  7. This should remove the key combination to launch Outlook.
  8. You should not have to logout/login, nor have to reboot for this change to take effect.

Now, test this out by opening up a Google Chrome window (one that is already executing is fine), and type CTRL+SHIFT+N. It should now open up the incognito window.

| improve this answer | |
  • I read your entire today's answer and I see it reproduces the solution I wrote you 6 days ago. I kindly ask for the feedback whether the solution was clear enough or not. – miroxlav May 22 at 20:53
  • @miroxlav I do not understand the phrase "it reproduces the solution". I did reference your answer in my answer, and stated that it was invaluable because of the possibilities that it eliminated. So your answer was helpful and was well written. Your answer was not a solution, but was instrumental in helping me find the solution, because it led me to look for answers on the Microsoft site. – bgoodr May 23 at 13:57
  • 1
    Okay, in the last paragraph of my answer, there was exact solution to find a shortcut icon on the Desktop or in the Start menu and remove the Shortcut key from it. You repeated that in details in your answer later, what is possibly OK. I am just asking, what was unclear when I wrote the same in my answer so I can improve that paragraph. Thank you. – miroxlav May 23 at 14:03
  • @miroxlav I did not see that latter answer upon first read. Either I just plain didn't read that far down and missed it, or it was subsequently edited and then added at the end. I don't know. Let's call it my fault for now. I've marked your answer as "the" answer. Thank you for sticking with it! – bgoodr May 23 at 18:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.