0

I am running Hyper-V on a Windows 10 system (host). I have a Windows 10 VM I am connecting to.

I am having difficulties connecting the VM to the internet and my local network. I have created a new Virtual Switch in Hyper-V as follows: Virtual Switch

I have assigned the virtual switch to my VM as follows: VM - Virtual Switch

In the VM I see I have no internet connection available. No Internet Connection

I opened Network and Connection Settings. No Internet in Connection Settings

This is what I see in Connection Settings:

No Internet

When I click on either entry, I see the following: Connection Options

I can't figure out how to get this VM connected to the host machine/local network/internet. I've googled and tried several different approaches (PowerShell). Shouldn't I have the option to set between a "Public" and "Private" connection? This does not show up in Windows 10.

What am I doing wrong? How can I get this to work correctly?

Thanks, JohnB

1
  • I would have thought that would work. Only two things I can suggest: Why is that switch also connected to the "legacy network adapter" in your VM - in fact, why do you have a "legacy network adapter" in your VM? Second (this is a dumb suggestion, yet possible): Does your computer have >1 external network port and if so, did you connect your new virtual switch to the right one? (I.e., the one that has the network cable hanging out of it ...) – davidbak May 19 '20 at 23:57
-1

I was using the incorrect external network connection type in the Virtual Switch Manager. I was using Ethernet instead of the WiFi.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy