2

I have an old (2005) Sony VGN-A197 laptop (variously sold as the A50 / A130 etc depending on region). I wanted to rejuvenate it.

I installed lubuntu on the HDD and upgraded the RAM from 512MB to 2GB. I used a DVD ISO installer I made myself. This all worked fine, system boots into lununtu from the HDD and works as expected.

Next I upgraded the 80GB HDD to a 32GB SSD (don't need the extra space).

Did the replacement, re-ran the installer, everything seems fine - but can't boot from the SSD. I just get a black screen and a flashing cursor.

I then booted from the install CD and re-formatted the SSD fully. Checked that it mounts and that I can read and write from it. The SSD seems fine - all works as expected.

Re-ran the installer, did a standard install, system still won't boot from the SSD.

I'm at a loss as to how to resolve this. The BIOS recognizes the SSD OK and the boot order is DVD then SSD. Changing the boot order didn't make a difference, it just failed slightly faster. I don't see any options in the BIOS that would help.

What might be preventing the BIOS from booting from the SSD? Is there anything else I can try or more diagnostic information I can find somewhere? I'm only pleased I didn't put back the 28 screws yet ...

UPDATE JUNE 7

I briefly thought I had solved this by running boot-repair. I booted back into the install DVD and then ran;

sudo apt-add-repository ppa:yannubuntu/boot-repair
sudo apt update
sudo apt install -y boot-repair
boot-repair

I kept the log of what it did here http://paste.ubuntu.com/p/pqSsPVmsfR/

Thought this had fixed it, I could have sworn it booted at least once from the SSD, but it's not working now. I've also found the original restoration CD and that didn't work to the SSD either - it all seemed fine, I could read the disk OK, but on booting it said Invalid partition table.

I have also tried restoring the MBR to no avail. I'm starting to think the old BIOS simply doesn't like the SSD for some reason even though it can read and write from it.

Incidentally, when I boot back to the ubuntu live-cd and run gparted, it all looks fine.

I've abandoned the process now and put the original HDD back in, that works fine and the full system restore also works fine so everything is pointing to a problem with the SSD compatibility it seems.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.