0

I have a Asus X570-E motherboard with a couple drives connected in raid on the SATA bus. I've set the SATA mode from AHCI to RAID, and configured the raid successfully.

However, today when I connected an Optical Drive I've discovered that having the SATA mode set to RAID and having an Optical drive causes Windows to freeze and crash whenever accessing the disk. Not bluescreen or produce an error, but freeze Windows Explorer and various other programs until I hard restart, or wait a good 5 minutes. I.E. Opening windows explorer, opening device manager, opening VLC and attempting to play the disc, or anything else that might cause windows to poll the Disc Drive.

Turning off RAID on the motherboard causes the disc drive to work normal, and setting it as disabled in device manager will also avoid issues. However, I can't seem to figure out how to keep my discs in a RAID, and have my disc drive work?

My Disc Drive is a Pioneer BDR-207D, with updated firmware and using the generic CDROM driver from Windows (6/21/2006). Has anyone had this problem before? What workarounds would you suggest while keeping my discs in a RAID?


I've flashed the bios to factory defaults and recovered the array, and have seen no change. For good measure, I reinstalled windows as well and encountered the exact same bug during the install. In order to see the RAID drive you must install the motherboard RAID drivers. After doing so during the install the DVD drive appeared as another device, when I clicked on it the entire install froze and crashed.

This appears to more of a RAID driver issue than anything else. Just how it handles disk drives I guess. I went ahead and sent a message to ASUS regarding this.

  • All I can suggest is to try a different sata port for the optical drive – Moab May 22 at 12:49
  • If that does not work installed the latest bios update>>>>>>>asus.com/us/Motherboards/ROG-Strix-X570-E-Gaming/… – Moab May 22 at 12:56
  • Tried different a SATA cable and port, didn't change anything. I flashed the bios completely and recovered my array, still no change. I'll be chatting with Asus about this in the morning. – freebird May 22 at 14:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.