I have a not-so-recent HP desktop PC (model# m9510f, Q8200 CPU - I think it was manufactured in early 2009 sometime, because it still had Vista 64-bit).

I've set it up with a pair of 500GB drives that I want to run in RAID0 striped mode (for higher performance and lower reliability). I've successfully setup the RAID in the BIOS, and it is recognized at boot time.

Only problem is, Clonezilla won't recognize the RAID0, so I can't very well restore the OS. I could just reinstall from the recovery disks, but then I suppose I also won't be able to make Clonezilla backups either. Clonezilla only sees the individual drives.

What's the best way to get around this issue?


5 Answers 5


Clonezilla doesn't support software-based or firmware-based (aka "FakeRAID") arrays.

From what I understand your HP system has an Asus-made MB in it with an Intel ICH9R chipset. If you used that to make your RAID 0 then Clonezilla can't do anything with it.

From their About page (under "Limitations"):

Software RAID/fake RAID is not supported by default.

From their FAQ:

Q: Does Clonezilla support RAID ?

A: Clonezilla does support hardware RAID, if your RAID device is seen as /dev/sda, /dev/sdb, /dev/hda, /dev/hdb, /dev/cciss/c0d0... on GNU/Linux. Clonezilla does support this. On the other hand, if it's Linux software RAID, no, Clonezilla does not support that.

See here for a recent Clonezilla forum thread about using it (or rather, NOT using it) with firmware-based arrays.



Can't help you with Clonezilla as it appears from the previous poster that it simply will not work. If that's the case, use something else. Want free (as in no license fee)? Then you can use Microsoft's ImageX program. Image your old system with that to an external drive, then restore it. ImageX is a command line tool that is freely available within the Windows Automated Installation Kit. Using that kit, you can (if necessary) create a WinPE boot DVD that includes imagex and the drivers for your RAID controller. If windows can see the drive as you want it, you can deploy the image (note: if your Vista install (or whatever version of Windows you use) doesn't have the appropriate drivers for the RAID controller IN windows, then it may not boot at all - it would be wise to install the drivers BEFORE making the image). There could still be other issues - a possible need to make the drive partition "active"... but the imaging part of the problem should be solved with this solution.


During my Google search for this problem, I saw a post that I thought was interesting, and worked for me when I tried it. (Caution: this only works for RAID 1 and possibly RAID 10).

Unplug one of the drives. Then boot clonezilla. The RAID array will be "degraded". Then restore the image to the active drive, shutdown, plug the drive back in, and the array will rebuild. I'm currently watching a copy I just made this way and it seems to have worked great.

The trick is that, since this is software RAID, the RAID info is stored on the drive. I only restored the partition, not the full drive, and I left the MBR as is (using the clonezilla advanced options). Make a comment if other options worked for you.

Edit: I'm testing with a Dell Precision 390, with the Intel Matrix RAID built into the motherboard.

  • @ Nathan Garabedian - Could you provide more detailed information about the MBR configuration? I have the intel matrix raid on 2 x 500GB hard drives but I get a blue screen when I attempt to unplug one drive and then restore a clone from a single disk image. I could really use some guidance on this one and it would help me out tremendously at work.
    – user166268
    Oct 18, 2012 at 19:01
  • I believe I was using the Windows XP MBR, which clonezilla gives you the option to save when you capture the image. If you are running into problems with the MBR not restoring properly, you can try booting BartPE or the Windows XP Recovery boot to restore it. Check out mbrfix sysint.no/nedlasting/mbrfix.htm or the Windows Recovery tools. Nov 8, 2012 at 0:01

You can manually activate RAID support in Clonezilla. YMMV on success. The clonezilla image must have kpartx and dmraid as well as the necessary modules.

Running "dmraid -ay" should activate all the RAID arrays if your array is MBR-formatted. This is usually not the case for UEFI machines which are GPT-formatted, you need to add the command "kpartx -a" after running dmraid to activate GPT arrays.

Once activated the arrays should be available via /dev/mapper

However, even after RAID is activated, you need to manage the backups or restoration manually. This means it's up to you to issue the backup command from command prompt. Clonezilla does not allow selecting volumes from /dev/mapper, but it's not an issue if you call the backup command like partimage and point it at the volume directly. You will also need to backup the disk parameters, that should be doable using gdisk.

Good luck!

  • Have you actually tried this? After following these steps, ocs-sr restoredisk tells me the disk at /dev/mapper/ist... is an unknown hard drive device and terminates.
    – Elliott B
    Jan 18, 2019 at 0:15

It's a little disappointing but as it seem when they created clonezilla they didn't care for RAID. Well in the end I did my copy job with partimage.

My new RAID0 is at \dev\dm-0 The source disk with an GPT is \dev\sdd

I booted into the clonezilla and hit alt+F2 to get a command line:

cd \dev
partimage.dd -b -ssdd -Odm-0

if time doesn't matter keep it running.

... or if you don't like to wait that long. hit Ctrl+c. To copy just the used data is much faster.


gdisk \dev\dm-0

and 'w' to write new fixed GPT (and it's backup)


will make the kernel to read the new partition layout and as well spot any partition problems.

blk -f

to get an overview about what partitions are there. Now I manually create my long commands line batch :

cd \dev
partimage.ext4 -b -sssd1 -Omapper/isw_...RAID1 ; partimage.ntfs -b -sssd2 -Omapper/isw_...RAID2 ; partimage.fat32 -b -sssd4 -Omapper/isw_...RAID4

(This job 'normally' OCS-Clonezilla would do. ) I chain the commands together with ; However if you choose to make use an editor to do (nano, mcedit, vim...) so you don't need the ';' . Just put each command to a new line. Stay away from /dev/dm-X since it's not that clear what partition they stand for. Instead use /dev/mapper/...

Okay that's it.

I recommend to boot Clonezilla with a resolution of 1024x768. That'll give you a better overview on the screen. You've no windows however Alt+F2, Alt+F3 ... will change the tty and can be useful to do some task in another tty and then switch back and forth.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.