1

I pulled an 80 GB WD hard drive out of my father's old (90's) IBM desktop computer. The only special thing about it is that it was once cloned from a smaller HDD as an upgrade to the 80 GB one (meaning nothing fancy like disk encryption should be expected).

I've been trying to do data recovery of the computers sitting in our basement (quarantine life), and this one is giving me trouble, not just because we lost some of the hardware to make that particular desktop boot. When I run fdisk /dev/sda from my (Arch) Linux setup, I'm seeing this:

Disk /dev/sda: 74.54 GiB, 80026361856 bytes, 156301488 sectors
Disk model:                 
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x0d179feb

It doesn't print out anything else indicating that it has partitions at all. I found the partprobe tool:

/dev/sda: msdos partitions

I also found the testdisk tool, but playing around with it, it didn't find partitions either (at least when I was selecting the Intel option). I tried Western Digital's analysis tool over in Windows too, but even their "extended test" gave the disk a pass.

Any help on getting this disk mounted please?

  • It is now at the point (20 years later) that you would need to use professional recovery tools and parts to see if data could be recovered. – John May 23 at 0:57
  • 1
    How about if you do ddrescue on it to get the hard drive in a file, then run testdisk on that. (which is what you are supposed to do anyway) – barlop May 23 at 0:59
  • I'll try ddrescue, wasn't familiar with it. Thanks. Don't wait around for me, I'm a slow one – Joshua Detwiler May 23 at 1:03
  • 1
    Let's say you tried to get that old computer to boot though. What hardware did you lose?! – barlop May 23 at 1:17
  • Also, does DOS's FDISK see anything? So if you plug that old hard drive into a new computer and boot DOS. (how to boot DOS is another subject but it's doable) . – barlop May 23 at 1:19
0

As @barlop suggested, I ran

$ sudo ddrescue /dev/sda hdimage mapfile
GNU ddrescue 1.25
Press Ctrl-C to interrupt
     ipos:   80026 MB, non-trimmed:        0 B,  current rate:  22700 kB/s
     opos:   80026 MB, non-scraped:        0 B,  average rate:  25957 kB/s
non-tried:        0 B,  bad-sector:        0 B,    error rate:       0 B/s
  rescued:   80026 MB,   bad areas:        0,        run time:     51m 22s
pct rescued:  100.00%, read errors:        0,  remaining time:         n/a
                              time since last successful read:         n/a
Finished

Then, since all I did was copy the disk to a file, I tried a hexdump to see what I really had. It's nothing. And that's why there are no partitions. Look at when I try to hexdump this whole disk (it's the same on hdimage):

$ sudo hexdump -C /dev/sda
00000000  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
*
00181e00  ff ff ff ff ff ff ff ff  ff ff ff ff ff ff ff ff  |................|
*
12a1f16000

So, it looks like that data isn't coming back. The disk is basically all 1's.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.