1

I have HP Laptop with AMD A6 APU, Windows 10 1903 fully updated. Realtek RTL8822BE 802.11ac WiFi adapter. I connect it to my WiFi network on Dlink 300M router. I face this issue only with this laptop, no other device on my Wifi.

Intermittently, completely at random (sometimes in just 5 minutes, other times after a few hours) WiFi appears connected but the Tray Icon changes to Globe, I cannot access the Internet and even though it indicates 'Connected, Secured, No Internet’ I am unable to even access the router admin page 192.168.0.1.

LAN & WAN connectivity is just fine from all other devices connected to the router at the same time. The only way to reconnect is to disable & re-enable WiFi on my Laptop. I have tried the following but it did not help

  1. Network Reset on Laptop
  2. Update WiFi driver
  3. Change channel in router
  4. Reset router and setup afresh
  5. Keeping the laptop in the same room as that of router, i.e. proximity
  6. BIOS is already latest, no further updates
  7. Router logs don’t tell anything except this line ath0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: disassociated (But I think it comes because I disable wifi on laptop before reconnect)
  8. I could not find anything related to wifi or network under system or application section around the same time it happens in windows event viewer
  9. Set DHCP reserved IP address to my laptop in router
  10. Disabled ‘allow device to turn off to save power option’ for WiFi adapter
  11. Overriding DNS to Google DNS in my wifi IPv4 properties in laptop

I have seen some similar questions on this site but I still could not find any definitive solutions therein. Wherever I found accepted solution, it was one of the above steps that I have already done. I am not keen on upgrade to 1909.

Here’s the snapshot of IPCONFIG command after this happens. What could be a possible fix to this issue?

Wireless LAN adapter Wi-Fi:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek RTL8822BE 802.11ac PCIe Adapter
   Physical Address. . . . . . . . . : xx-xx-xx-xx-xx-xx
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::25a8:241b:95bc:3ac2%20(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.0.106(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.0.1
   DHCP Server . . . . . . . . . . . : 192.168.0.1
   DNS Servers . . . . . . . . . . . : 192.168.0.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

A few similar questions already looked into.

Laptop randomly loses wifi connection

Windows computer connected to WiFi network drops off network every few days - debugging the issue

Windows 10 - WiFi periodically disconnects from university network

Connected to LAN but no internet access

  • I read through your complete list of checks and corrections. Now go into Power Management properties (advance power management) and set the Wireless adapter to Maximum performance. Should that fail, try a different USB Wireless adapter – John May 23 at 16:44
  • Thanks @John. Question updated with details. If say external USB adapter works well (I don't have one right now to test) would it mean some failure with the built-in wifi card? – rajeev May 23 at 16:57
  • Thanks for the screen shot. I was talking about wireless performance power management, not transit power. I leave all these settings as default and limit my changes to performance power management available in advanced power management settings. – John May 23 at 17:00
  • I could not find any advanced power management tab or a button or settings under power management option for wifi adapter as shown in the screenshot on left. I am not very sure where to look for the same. – rajeev May 23 at 17:04
  • The screen shot is for the Device. Right click on the battery, select Power Options, Change Plan settings, then in the next screen, Change advanced power settings, then see Wireless Adapter settings and set Performance to Maximum both battery and Plugged In. It should be there and that setting (Max Performance) should help you. – John May 23 at 17:13
0

Do you have internet connection if you connect your computer directly via a LAN cable to your modem?? Just to check.

A similar 'no internet connection' problem occurs when your Wifi is still 'On Air' but someone pulled the cable-internet cable from the modem. The Wifi carrier is still there, but there is no traffic.

But as you wrote that the other computers in your house don't experience an internet connection problem, that might not be the problem.

Another thing to check, is if there is valid DNS info in the Network settings in your Windows 10 system.

Go to settings, 'View your Network Properties', and check if your see DNS info in the overview.

If there is no DNS info available, open the settings for the wireless interface by double clicking on it.

Just enter: 8.8.8.8 (this is the Google DNS) for primary DNS server and 8.8.4.4 (also Google DNS) as the secundary dns server.

Click OK/Apply/Save. To make sure, just reboot Windows 10 and try again.

Another problem an be that a firewall is blocking traffic, but if you didn't change anything, I wouldn't worry about it.

Good luck!! Robbert / PA3BKL

| improve this answer | |
  • 1
    Thanks for the input. As mentioned in my question, I already tried overriding DNS to google DNS on my laptop but that did not help. – rajeev May 23 at 17:07
  • - Do you have internet connection if you connect your computer directly via a LAN cable to your modem?? Just to check. - Not that easy to test because my router MAC is bound to ISP. I need to fiddle with spoofing MAC on my laptop lan to try that. – rajeev May 23 at 17:11
0

Just thought about another thing.

Are you on a 2.5Ghz wireless or are you using 5 Ghz. The 2.5 Mhz band has only 11 channels, and if you are in a densely populated area, there could be Wifi congestion, and you might experience this problem because of interference from other Wifi signals.

If you have 5Ghz wifi available, change to 5 Ghz. Not many people are using 5Ghz, and also the 5 Ghz band has more channels, and less interference because of a shorter range.

You could also try to change the Wifi channel in your modem. In some modems there is an channel auto-selection fetaure. If you enable that, the modem seeks an empty or less busy wifi channel.

Just experiment a little with that.

Cheers Robbert

| improve this answer | |
0

This is most likely due to one of the reasons:

  1. Blocking by Mac address, for example, router protection for some reason has blacked your Mac address, or it was limited in the settings

1.0 try to whitelist the Mac address of the device, if there is one and reset the blacklist, there are interesting effects if it is full.

1.1 try setting static wifi settings on the laptop, add its Mac address and IP address to the exception in the DHCP pool

1.2 try if 1.1 comes out, configure the statics via DHCP on the Mac address of the laptop providing the IP address

this will indicate problems with reinitializing the settings of the network wifi card, most likely this is a problem with the driver

  1. poor compatibility between the antennas, it happens that the antennas do not understand each other, try to put a signal amplifier, in fact you will replace the antenna not quite so, but close in effect
  2. problems with channels - try changing the channel on a wifi router
  3. conflict between devices on the laptop, for example, a wifi connector is installed with support for keyboard, mouse, docking station and so on

4.1 look at other devices, especially those with plug-in radio devices, IOT helps you a lot when turning on the devices

  1. directionality of the antenna, or directionality and amplification of the signal (try to walk with a laptop at the wifi router to start) and determine the most free channel also see point 2.
  2. Overheating of the wifi card on the laptop or disconnecting one of the antennas on the router due to overheating

There is a 7th reason, it does not fit in your case, but may be useful to someone else.

  1. rarely - incorrect editing of the wifi network card properties in the vendor tables, when the hardware is blocked at the BIOS level I exaggerate, but I indicate the mechanism

it's a marketing thing limiting plug-in equipment

for example, you decide to deliver equipment not from a list specified by the seller Accordingly, you need to either check the list of wifi network cards that can be put on your laptop

or arm yourself with the necessary low-level tools and knowledge and change the lists (minus the approach, the laptop can become a pumpkin (brick))

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.