11

My icons decided to s p a c e out a bit for some reason, and I can't seem to fix it. I've tried googling solutions, but to no avail.

Here's a picture:

enter image description here

Quite spaced out and kind of annoying. Could someone please tell me how to reset to Windows' default desktop icon scheme?

Thanks in advance.

3
  • try CTRL + scrollwheel
    – LPChip
    May 24, 2020 at 13:41
  • Tried, spacing also increases with icon size.
    – Virtuality
    May 24, 2020 at 13:44
  • You can also try changing the DPI settings and change the windows theme. The icon spacing is a theme setting, so changing the theme may resort it. Alterantively its somewhere in the registry (which is what the theme would adjust)
    – LPChip
    May 24, 2020 at 13:45

8 Answers 8

18

DISCLAIMER: Take caution when using Registry Editor.

  • Change the IconSpacing and IconVerticalSpacing values in Registry Editor to the Windows default value of -1128:
  1. Open Registry Editor by hitting Win + R and typing regedit into the Run box.

  2. Hit Enter and click 'Yes' to open Registry Editor.

  3. Navigate to following:

    HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics
    

    You can paste this in the "address bar" in registry editor window

  4. Change IconSpacing and IconVerticalSpacing values to -1125 by double-clicking on them and modifying the current value.

  5. Save changes and exit Registry Editor.

  6. Reboot your machine.

7
  • 2
    worked perfect. did not see any side effects Mar 27, 2021 at 3:52
  • 2
    picture shared in the query is not worth to be considered for "icons spaced out". I had Windows 10 new release update very recently. and the resolution made me little panic. desktop icons were literally far from each other as if they are following "social distancing". navigation to icons not visible on the screen were accessible like we do "Read Mode" in "MS Word". This answer gave better direction and resolved the issue. Mar 27, 2021 at 3:58
  • 1
    After changing Screen Scale from 125% to 100% this also happened to me, when selecting an icon I could see its transparent region was 3 times bigger around the icon image. And this makes a huge space between icons. This solution fixed it. Apr 16, 2021 at 19:01
  • 1
    I use -840 for both spacings, and shrink them with desktop | right click | View | Small icons. And DesktopOK to keep them where I put them.
    – Bob Stein
    Jul 30, 2021 at 19:10
  • If that works for you, then it's fine.
    – Virtuality
    Aug 1, 2021 at 22:51
2

Right click on the Desktop and select View, then Small Icons. The icon setting for Small, Medium or Large Icons is the only setting that affects Icon spacing for a given resolution.

Check that your resolution has been set to native for your display.

Make sure in Windows 10 Settings, System, Display that Scale and Text size are normal. If System Wide text size has been enlarged, this would cause Icons to space out. Check text size by searching Settings for "Make Text Bigger" and set to 100%.

2
  • Resolution has been double-checked and is the native resolution for my display, and I tried changing icon size; the icon size changes, but the spacing doesn't change.
    – Virtuality
    May 24, 2020 at 13:48
  • I added some settings information on text size which may have changed and cause icons to space out.
    – John
    May 24, 2020 at 13:54
2

This problem came up for me today and as Angus says, simply restarting windows explorer fixed it.

An even easier way to do this on Windows 10 is to just restart it from the task manager rather than command prompt.

This is a much simpler fix than editing registry entries as suggested in the top answer. It cannot be fixed by adjusting the icon size to small/medium/large etc as that is not causing the problem as OP said.

2
  • I went through various troubleshooting steps, including checking the registry, to no avail. Restarting Windows Explorer did the trick. Nov 9, 2021 at 16:51
  • Did not work for me.
    – Rd Basha
    Feb 3 at 11:41
1

This happened to me when OneDrive decided to change the Desktop Location to the cloud. Once I've changed the location back to default and restarted, all reverted back to normal.

1

Easier way to solve this is to open Task Manager, find 'Windows Explorer', right click and press Restart. This solved it for me

1

It happens sometimes when connecting a second display to a laptop. In Windows 11 the IconSpacing were right and resetting Windows Explorer didn't work neither.

Restarting the computer worked (maybe just restarsting the session could work too)

1

The spacing grid is controlled by values in the registry, as explained in the accepted answer.

For those who don't like clicking around in the registry editor, here is the alternative for copy/pasting into the command-line window:

To see the current settings:

reg query HKCU\"Control Panel\Desktop\WindowMetrics" | findstr Spacing

To change it, use values between -480 and -2780. The default is -1125 (or -1128?).

reg add HKCU\"Control Panel\Desktop\WindowMetrics" /v IconSpacing         /d "-1125" /f
reg add HKCU\"Control Panel\Desktop\WindowMetrics" /v IconVerticalSpacing /d "-1125" /f

To see the result, you need to Sign out and Sign in again. (restarting Explorer doesn't seem to be enough)

To change the icon size, you can click on the Desktop, and Ctrl-scroll with the mouse.

1
  • Thank you. When I applied the change and restarted Explorer, the icon spacing got much worse, about double even what it was. A system restart did fix it.
    – MichaelE
    Nov 15 at 22:39
-1

I've had this problem - I think after using an external display for my laptop. Even when icons were resized to be tiny, windows put huge amounts of space between them.

Solution: Restarting explorer.exe fixed the problem for me, without needing to edit the registry.

  1. Hold windows key, press X then C, command prompt should open
  2. Type "taskkill /f /pid explorer.exe", press enter
  3. Type "start explorer.exe", press enter
1
  • This happened to me with external display with lower DPI also. Probably some bug in the DPI scaling state. Restoring explorer.exe works
    – Keegan Jay
    Aug 20, 2021 at 0:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.