I have (64-bit) Cygwin install on my Windows machine; and I'm also using mobaxterm 12.4.

How do I get my mobaxterm to...

  • Start a Cygwin shell session? Or better yet
  • Use Cygwin as the default when launching a "Local Terminal"?
  • Have you tried the mobaxterm cygwin plugin? MobaXterm Xserver with SSH, telnet, RDP, VNC and X11 - Plugins
    – DavidPostill
    May 26, 2020 at 11:34
  • the internal mobxaterm terminal is a cygwin, in configuratio->terminal->local shell you have different options (cmd, powershell, zsh,...) but no options to add an external one.
    – Zina
    May 26, 2020 at 11:35
  • @DavidPostill: What plugin exactly? There isn't a plugin named "cygwin".
    – einpoklum
    May 26, 2020 at 12:02
  • @Zina: That's... annoying :-( I want it to use my full-fledged cygwin, with the Cygwin home directory for my user and everything.
    – einpoklum
    May 26, 2020 at 12:03
  • well, maybe running cygwin from within the mobaxterm local terminal might work, look into the execute command on start option...maybe you will be able to work around it with it
    – Zina
    May 26, 2020 at 13:33

2 Answers 2


it's also possible to create a shell session with the 'Bash (external)' option

Menu Sessions -> New Session -> Shell -> Bash (external) -> Advanced Shell Settings -> Distribution Directory -> C:\path\to\cygwin64

tested with version 22.3


The trick is to use a CMD terminal that starts a cygwin BASH session upon startup, as follows (adapt the cygwin location and the user to your situation):

MobaXterm | Session | Shell | Terminal Shell: Cmd | Advanced Shell Settings | Execute:
set HOME=/home/<user>;
C:\\Localdata\\cygwin64\\bin\\bash --login

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.