1

I added repository "deb http://ftp.de.debian.org/debian jessie main" (i used this). I started the installation:

sudo apt install libpng12-0

But the error comes out:

dpkg: error processing archive /var/cache/apt/archives/libpng12-0_1.2.50-2+deb8u3_i386.deb (--unpack):
Failed to install new version “/usr/lib/i386-linux-gnu/libpng12.so.0”: No such file or directory
Errors occurred while processing the following packages:
/var/cache/apt/archives/libpng12-0_1.2.50-2+deb8u3_i386.deb
E: Sub-process / usr / bin / dpkg returned an error code (1)

I extracted file libpng12.so.0 from this package and placed it in directory /usr/lib/i386-linux-gnu/.

But at installation start: sudo apt install libpng12-0 the same error comes out. In this case, file libpng12.so.0 in directory /usr/lib/i386-linux-gnu/ disappears.

If I install the package via gdebi, the error is as follows:

/usr/bin/gdebi:113: FutureWarning: Possible nested set at position 1
c = findall("[[(](\S+)/\S+[])]", msg)[0].lower()
1
0

I am our answer here. Deliver this package from repositories Debian 7 wheezy.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.