1

I need to import a rules file(.rwz) shared by a colleague in my Outlook application (version 13). I have created the required folders.

When selected the file to be imported, all the rules appear correctly with correct folder names too. But then I click apply and it shows below error. After clicking ok, folder names from each rule changes to specified folder and all rules turn red.

Kindly suggest. Thank you for your help.

enter image description here

Edit - This link https://www.msoutlook.info/question/138 suggest that "After importing your rules, you might need to relink all the “move to folder” rules to the correct folder again, even tough they might seem still correct."

The question remains how to correctly import the .rwz to avoid the folder names getting reset from all the rules?

1
  • msofficeforums.com/outlook/… this thread mentions same issue, unfortunately, with no answer. though it suggests that there is maybe some unique ids for folders which might cause this. I have searched all over internet, but could not find answer to the issue. – Raja Dorji May 30 '20 at 16:27
1

According to screenshots, this issue most frequently happens when you import rules that had been exported from some other machine (or possibly from a different Outlook profile). The errors are usually folders that do not exist in your new Outlook folders, because Outlook does not build the folder structure on your behalf.

More details in this article may be helpful to you, you could follow steps in the article and check if this issue continues.

1
  • Thank you for answering. Even if I create the folder structure before importing, I am getting the folder issue. Only one rule is imported correctly which does not have any folder mentioned in the rule. For others, folders names are reset and rules get inactivated. – Raja Dorji Jun 1 '20 at 13:21
0

Answer by @Joy Zhang also seems a good solution. But my org does not allow installing outlook plugins, so I cant verify. Later I realized, the correct steps to import rwz. You have to create each folder manually in this solution.(Fyi, it looks like you will come across this issue only when importing rules exported from different outlook profile).

When you import .rwz file to your outlook app (find the import/export settings in outlook, click on import, browse the rwz file, click open), before clicking on Apply, you have to relink the folders to each rules.

  • Select each rule
  • click the folder name, from the rule option - "move it to foldername here"
  • a window will open showing folders, notice that Inbox folder is selected by default
  • select the correct folder(or create one if not done before import)
  • do this for all rules dealing with folders
  • click on Apply after manually re-linking correct folders to each rules
  • click ok

Rules are set. Click the option "Run rules now" to run the rules on existing mails.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.