1

edit: This seems to have been patched in the latest version of the vmware workstation.

So I was enjoying life for a while, but then vmware decided that my caps lock key needed to be more non-deterministic.

This occurs across two different VMs (I created a new one just to ensure that it wasn't something I did on the old one).

When caps lock is enabled, it cannot be disabled. Sometimes if you type a long sequence of letters, it will turn off for a second, but then comes right back. I opened up xev to see what was going on, and sure enough, I was getting a constant stream of caps lock keypress events.

Another important fact: it doesn't happen in TTYs. Only in an X11 environment.

I thought it was my vmware host tools, so I updated them. No dice.

I reinstalled open-vm-tools on the guest, and triple checked to ensure they were enabled and all of the kernel modules are loaded. No dice.

I re-installed vmware entirely. No dice.

What could possibly be causing this? Here's a video I made in case my description isn't clear enough.

https://www.youtube.com/watch?v=mkMg6BoQhYg

1

This is a known issue with VMWare Workstation 15.5.5

A VMWare employee has suggested to set the configuration

mks.win32.useInjectedMagic=FALSE

as a workaround here which solved the problem for me.

EDIT: According to the 15.5.6 Release notes, this issue has been resolved.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.