3

Previous post

I have a Huawei WiFi router that has 4 ethernet ports. I have connected one of those to my laptop and connected another to device via an ethernet cable (RFID reader). I run the software Advanced IP scanner to scan all the devices on my network. But the connected device (RFID reader) fails to be detected by the software. The RFID reader is powered.

Can someone please explain to me why this frustrating network RFID reader fails to pick up on the software. As mentioned in my other post I want to know the IP address of the reader?

2

As davidpostill mentioned in the bottom of his answer, you either need a real serial port (db-9) on the computer you are trying to use with this
enter image description here



Or you need to purchase a serial to USB Adapter, enter image description here

Most consumer computers do not come with these ports built in any more, they are considered obsolete for most applications. USB & Firewire replaced it for most peripherals.

Make sure when you do purchase one that with drivers are compatible with the version of windows you are using. (Usually listed in the product description)

Once you have the drivers for the new adapter installed, plug it in and go to device manager, Start -> type device -> click on "device manager". In device manager you should see a section called Ports (COM & LPT). dev-manager Note the communications port that comes up when you plug/unplug it. (in this example its named COM1).


Now that you have a com port to use with your PC. Open the RFID Software with the RFID connected via USB to Serial adapter. RFID-software

  1. Choose the COM port that you found in device manager.
  2. choose the speed for the COM port and click open. (Note the speeds that I found online said up to 57600bps. If that doesn't work, these are some of the common serial speeds under that rate, 1200, 2400, 4800, 9600, 19200, 38400,)
| improve this answer | |
  • Looks like this reader is a complete fake. I bought the serial to USB adapter and followed the steps above. Now it says Serial Port Error!. I am going to break this reader! Sorry for wasting you time Tim :(. Thanks for all the help! – Joey Jun 1 at 18:55
  • I currently have a new stress reliever. I going to get my money worth by hitting this reader with a hammer and all this stress will go away. What would you say is a good RFID reader that connects via ethernet and also comes with an SDK? – Joey Jun 1 at 19:06
  • 1
    Should also have mentioned to restart the PC, and make sure the USB to serial is plugged in before you start the software – Tim_Stewart Jun 1 at 19:32
  • 1
    Serial stuff isn't plug and play... – Tim_Stewart Jun 1 at 19:32
  • 1
    Still doesn't work. I going to go and have some alone time with a hammer and this reader. Might go watch the S[aceX launch again to get some inspiration back.Thanks again Tim! – Joey Jun 1 at 19:41
2

This frustrating network RFID reader fails to pick up on the software

The reader you bought ACM812a RFID reader does not support TCP/IP.

Supported protocols are RS-232 (serial) and RS-485 (also serial):

enter image description here

You will need to connect the device to a serial port on your computer. If you don't have one you can purchase a USB to serial converter.

| improve this answer | |
  • Thank you! I thought since the reader had a rj45 connector already attached to it, it supports tcp/ip. – Joey May 31 at 16:58
  • @Joey No problem, please don't forget to accept the answer by clicking the accept button (the tick ✓ button) – DavidPostill May 31 at 17:02
  • The rj45 connector also has 4 wires connected to it. And I checked those wires are soldered on the pcb. So it operational and not a dummy connector. So doesn't this mean it supports tcp/ip? – Joey May 31 at 17:02
  • The spec says it doesn't. You should contact the manufacturer to clarify. – DavidPostill May 31 at 17:04
  • 🙈 Definitely think I have been scammed then! Never trust Chinese product I guess – Joey May 31 at 17:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.