14

My company has made our Win10 users to be "standard users" (without admin rights). However, there is a possibility to run a program using admin rights with some "auto elevation" (Avecto Defendpoint?) system. What I would normally do is "right click" -> "Run as administrator", but that option is not available with Device Manager. I am able to run Powershell as admin, for example (with Right click -> Run as Administrator).

How would I open the Device Manager with Admin rights?

What have I tried and which does not work

  • Right clicking "Device Manager" in start menu -> "Run as Administrator" (there is no such option)

  • Running with Win+R -> devmgmt.msc. (It starts with standard user rights)

10
  • 1
    Try SuRun and be done with it ;) ... typically when you want to run something as admin you need to prefix the command with runas. In case of the device manager you'd start the devmgmt.msc MMC snap-in and presumably via mmc.exe ... which in turn could be prefixed with runas. Jun 2, 2020 at 10:11
  • There is not really a need to run Device Manager as Admin. The components inside (to update, change, install) need admin rights. Why do standard users need Device Manager? We do not see this at our clients.
    – John
    Jun 2, 2020 at 10:55
  • @0xC0000022L Well that's an interesting option, actually. Only thing is that I would want to read the source and compile the software myself before using it, so if there is an option without 3rd party packages, it would be better.
    – np8
    Jun 2, 2020 at 10:59
  • @John Well there are certain situations I might need run Device Manager as Admin. Currently, I need to test a USB device with two different drivers, and for removing/reinstalling drivers I need admin rights. Maybe the question then is why I am a standard user, lol.
    – np8
    Jun 2, 2020 at 11:01
  • You need Admin credentials to do the installs you want. No way around that.
    – John
    Jun 2, 2020 at 11:18

8 Answers 8

18

Found a satisfying solution. Just start up Device Manager normally (without admin rights), and then press "Change Settings" -button in the General tab:

device manager general tab

This will open up the Properties window again but with Admin rights (at least, with the Defendpoint Auto-Elevation).


It is also possible to open the Device Manager with admin rights from a Powershell with admin rights with

start "C:\Windows\System32\devmgmt.msc"
4
  • 1
    No problem to open Device Manager. The issue comes with driver install and uninstall
    – John
    Jun 2, 2020 at 11:19
  • 1
    Why the downvote? This works as intended. Got my drivers uninstalled without any problems.
    – np8
    Jun 2, 2020 at 12:28
  • @np8 - This does not actually launch Device Manager with elevated rights.
    – Ramhound
    Jun 2, 2020 at 13:22
  • 1
    It does. Note that I ran it from Powershell with admin rights. When launching Powershell with admin rights, I get a UAC prompt (or similar).
    – np8
    Jun 2, 2020 at 13:29
5

Step 1: Run Command Prompt as administrator

Step 2: Type devmgmt.msc and press Enter

enter image description here

2

Here's another solution:

You can start the Computer Management (compmgmt) as administrator the usual way. In there you have a node to open the device manager as pane inside the computer management window.

2

Old thread, but thought I'd give me two-pennies worth.

  1. Right-click an empty space on the desktop
  2. New > Shortcut
  3. In the Create Shortcut Wizard, type "devmgmt.msc" > click "Next"
  4. Name it "Device Manager" > click "Finish"
  5. A shortcut will appear on your desktop
  6. Right-click the shortcut and select "Run as Administrator"
2

Open Win+R, type devmgmt.msc

Now do not click OK, but use ctrl+shift+enter

This will start it as administrator.

2
  • Downvote because this Option was removed by Microsoft together with the Right-Mouseclick option. This does not work anymore. Apr 28 at 0:55
  • I tried it on my Windows 10 machine and it still worked.
    – LWChris
    Jul 29 at 12:15
0

you can open devmgmt.msc from cmd with admin rights
or you can open task manager>file tab > new task > check the "run with administrative previllages" option and open devmgmt.msc

5
  • The Task manager -> "New task" does not seem to have an option to run anything with admin rights.
    – np8
    Jun 2, 2020 at 12:30
  • It's simpler to open an admin command line window and type "devmgt.msc" from there.
    – user1019780
    Jun 2, 2020 at 16:11
  • @Didier yes you're right.. that's actually why i put it as the first option
    – Douae Lhrx
    Jun 2, 2020 at 16:19
  • if you don't see that option in new task then try to just open the device manager as normal user, and when you try to edit something you'll be asked for admin password
    – Douae Lhrx
    Jun 2, 2020 at 16:22
  • Sorry, I must have missed it! That's usually how we do it when we remote assist users with driver issues and the like.
    – user1019780
    Jun 2, 2020 at 16:22
0

Run CMD as Elevated

If your company windows allows you to run some programs as elevated, try this:

  1. Type CMD on the windows search
  2. Right-click the command prompt and click Open File Location
  3. On the folder that opens, right click the Command Prompt shorcut and click Run Elevated

This isn't admin, but it gives you some rights, such as opening the device manager to try to update some drivers. I haven't fully explored the possibilities.

0

You can also launch MMC as admin, then add device manager to MMC as a snap-in. Additionally you can save that console as an msc file and then re-access device manager as admin anytime you open that saved console file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.