15

I just installed Windows 10 Pro (version 10.0.19041) and I noticed that the "Start menu" search (the one you get when you hit the Windows button on the keyboard and start typing) searches the internet, despite me having disabled this.

What I tried before came from this question: How to disable internet search results in start menu post Creators Update?

I updated the following in the registry:

Windows Registry Editor Version 5.00
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Search]
"BingSearchEnabled"=dword:00000000
"AllowSearchToUseLocation"=dword:00000000
"CortanaConsent"=dword:00000000

and I updated the following in the Local Group Policy Editor:

Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > Search

  • Allow Cortana: Disabled
  • Do not allow web search: Enabled
  • Don't search the web or display web results in Search: Enabled

Then I restarted the computer. Although initially this did work and the search no longer connected to the internet, now (maybe since a Windows update was installed?) it is searching again, I think through Bing since that is the logo it is displaying underneath the search results.

The ellipsis-menu in the search app says Build: 2020.06.03.6245959, in case that is relevant?

Edit: The reason I ask this is because I consider this a privacy issue. I press the windows key to start applications (which I find much faster and convenient than using my touchpad), but I don't want every keystroke to be sent to the internet.

2
  • 1
    The Search command uses a Microsoft site to even function, so you disabled all the above and of course, it no longer works. Normal. Why do you need to disable all this. Just point search to Documents. That works.
    – John
    Jun 4, 2020 at 18:09
  • 2
    It certainly is possible to disable the online search. However, what is not clear, is the reason the author is attempting to disable Cortana with regards to search on Windows 10 version 2004. That particular key is null and void on that version of Windows 10. The answers to the linked question do not apply to 2004.
    – Ramhound
    Jun 4, 2020 at 18:16

1 Answer 1

16

I don't know why Microsoft updated Windows 10 version 2004 to ignore their own Group Policy setting. I hope this is a bug because there are very legitimate reasons for organizations not wanting to enable web-search in the Start Menu and it would be foolish of Microsoft to wantonly open-up their users to security risks for the sake of driving traffic to Bing.

According to this page: https://www.bennetrichter.de/en/tutorials/windows-10-disable-web-search/ the DisableSearchBoxSuggestions policy for Explorer should work.

  1. Open regedit.exe.
  2. Navigate to HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Windows\Explorer (create the Explorer key if it doesn't already exist).
  3. Create a DWORD value named DisableSearchBoxSuggestions and set it to 1.
  4. Restart your computer (or kill and restart all Explorer.exe process instances).

I have the latest Windows 10 group policy ADMX templates on my computer and my domain controller and I don't see DisableSearchBoxSuggestions listed. This is curious.

Update

I just restarted Explorer.exe now and I can confirm it works, phew!

Screenshot proof (note the lack of "Web" options and the "Bing rewards" display is gone too):

enter image description here

Update 2:

So the DisableSearchBoxSuggestions registry entry actually corresponds to an existing Group Policy setting dating back to Windows 7. In the Group Policy editor you can get to it from:

  • Policies
    • User Configuration
      • Administrative Templates
        • Windows Components
          • File Explorer
            • "Turn off display of recent search entries in the File Explorer search box"

enter image description here

3
  • Works as of Dec 7, 2020 Dec 7, 2020 at 0:45
  • 1
    Works as of Aug 1st 2021
    – RiverHeart
    Aug 1, 2021 at 16:54
  • MS policy still ignored as of 2022, your registry entry still works.
    – mins
    Mar 30 at 17:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.