0

All of a sudden, I started noticing that my machine (HP Probook 640 G4, Windows 10 enterprise 2016 v1607) now automatically downloads PDFs anytime I click on a link to a PDF or click to download a PDF email attachment.

  • (I am using Chrome v83.0.4103.97, and files are opening automatically in Adobe Acrobat Pro DC v2018.011.20058)

Previously, the PDF would open directly in Chrome or a window would pop-up providing me an opportunity to pick the save location. I am not aware of any preferences being manually changed, and I do not believe any major updates have occurred.

How do I make PDFs no longer automatically download and instead provide me a browser window to choose my save location?

WHAT I'VE TRIED (and that has NOT worked):

  • Chrome > Settings > Privacy & Security > Site Settings > Additional Content Settings > PDF Documents > UNCHECK Download PDF files instead of automatically opening them in Chrome

  • Chrome > Settings > Advanced > Downloads > CHECK Ask where to save each file before downloading

  • Acrobat > Preferences > Internet > Web browser options > Use your browser to control viewing of PDF documents directly in the browser using Adobe Acrobat Reader or Adobe Acrobat. The following adobe product is currently available for use by browsers: AcroRd32.exe

| |
  • I have Acrobat V2020 and set up much like you. I have the same version of Chrome as you. For most files, Chrome asks where to save. For PDFs, it shows the PDF and you save from there. So I think what you see is normal and now how it is done in Chrome. – John Jun 4 at 21:49
0

I think I found a working solution by adjusting preferences in Acrobat and not Chrome.

I unchecked Allow speculative downloading in the background under the "Internet" preferences in Adobe Acrobat. (See below)

After doing so, I am given a "Save as" window popup 1) when I click on a link to a PDF in Chrome and 2) when I click to download a PDF email attachment -- both as desired.

enter image description here

An explanation of this setting from helpx.adobe.com:

Allow Speculative Downloading In The Background: Choose to allow the browser to continue downloading PDF pages from the web, even after the first page displays.

One downside: it's taking significantly longer to load this "Save as" window vs just a few weeks ago when I last had a PDF successfully open the same window. What used to take 2-3 seconds is taking more like 12-20 seconds to load. So I'm not sure if there are additional adjustments or fixes to further improve upon the working solution I describe here.

| |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.