After upgrade Ubuntu from 18 to 20 as guest in the VMWare using Windows 10 as host, the sound started to jump, crackling, stuttering, spiking. Some videos even didn't play. I tried to install other distros, like Q4OS Debian Based, NixOS etc. and both present the same issue.

I tried a lot of things and didn't find a good solution. Some people told to decrease the number of cores to 1, but it didn't help much.

1 Answer 1


After a lot of try-and-fail, I finally was able to fix this annoying issue!

Follow the solution:

  • On Windows 10 host, I found the configuration of my sound card and change the output to Studio Quality, 24 Bits 48000 Hz.
  • On Linux guest (in my case Q4OS Debian based) I edited the file /etc/pulse/daemon.conf and uncommented the line where I found default-sample-rate and I changed the value to 48000 like:

    default-sample-rate = 48000

  • I found a file with the name of my virtual machine in the root of the VM with the extension "vmx" and I added the line:

    sound.virtualDev = "hdaudio"

  • I reboot my VM guest and host.

And that's it! The sound now is smooth like the summer.

  • Thanks so much! This worked. My setup was Windows 7 both guest and host. Host was at "24 Bits 44100 Hz (Studio Quality)", guest at "16 Bits 44100 Hz (CD Quality)", and guest Device Manager "Sound, video and game controllers" was "VMware VMaudio (VMAUDIO) (WDM)" when the problem was noticed (crackling once or twice a minute). Adding sound.virtualDev = "hdaudio" fixed it. The guest "Sound [etc.] controllers" is now "High Definition Audio Device". I have then raised guest to "24 Bits 44100 Hz (Studio Quality)" (to match the host), and the problem remains fixed. No crackling at all.
    – user778992
    Jun 9, 2021 at 0:05
  • To qualify, there is no crackling when the system is not under stress. Audio in guest seems more susceptible to stress than audio in host (even after the above fix). E.g. if I open guest 2 while audio plays in guest 1, it might crackle (while audio in host would not).
    – user778992
    Jun 10, 2021 at 1:44
  • This also worked for me simply with an Ubuntu native machine, by only editing the pulse daemon config file and rebooting. Jun 21 at 17:28
  • Any solutions for pipewire? Dec 6 at 19:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .