4

For a while now I have the problem that explorer.exe sometimes starts using ridiculous amounts of memory. If I wait long enough it can sometimes increase up to 18GB (I have 8GB of RAM total but it uses mostly swap space). I'm using Windows 10 Home 1909 (build 18363.836).

I noticed using Process Hacker that explorer.exe opens literally hundreds of thousands of handles to the following registry key:

Computer\HKEY_CLASSES_ROOT\CLSID\{DFFACDC5-679F-4156-8947-C5C76BC0B67F}\Instance

(Peak today was over 628'000 handles total, almost all to this key, growing in the end with ~100 per second, adding up to almost 13GB until I decided to restart it.)

According to https://winaero.com/blog/clsid-guid-shell-list-windows-10/ this is the CLSID for the "delegate folder that appears in Users Files Folder", but I'm not sure what that means.

The contents are a single string with key CLSID and value {0E5AAE11-A475-4c5b-AB00-C66DE400274E}, which according to the same website is the "Shell File System Folder". (I don't really know how the CLSID system works.)

At first I presumed that it was probably some shell extension that I have installed, but I've already tried to disable most (if not all) of them and I still got a notification that explorer was using multiple GBs of RAM (in the meantime I wrote a simple program that checks for this). (I guess I'll continue trying and keep this updated if I do make a breakthrough.) Or could it be a problem that I gave icons to some folders?

Does anyone know what the cause might be? Or what I could do to further investigate the issue? If some specific useful info is missing, let me know! I'm not sure if this question has a higher chance of being answered on support.microsoft.com, but I'll try to ask it there if I don't get an answer here.

6
  • Do you have any new shell extensions? Jun 6, 2020 at 16:59
  • Also, if you go into the Explorer preferences, in View / Options, then in the Display / View tab (mine's in French, sorry), do you see an option to open folders in a different process? Is it checked? If so, uncheck it, and restart Explorer (not necessarily your PC, just the explorer.exe process in Task Manager). You can also log out then back in afterwards, but that's not mandatory. Your pagefile seems to be on the big side, if it peaks at 18+GB for 8GB of RAM. Setting it at a fixed 2048MB should be enough. That, or turn if off altogether, just to check on your Explorer RAM consumption.
    – user1019780
    Jun 6, 2020 at 17:32
  • Check for malware as well. What is happening is not normal on any machine working correctly.
    – John
    Jun 6, 2020 at 18:02
  • @user1686 I've had the problem for quite some time now, so I'm not sure if the problem started after a certain extension...
    – SWdV
    Jun 6, 2020 at 21:23
  • @Didier It's not checked, but I did notice that (at least this time) there were two explorer.exe processes running. I set my page file size to automatic. Is there a benefit to reducing the size? Sounds like the RAM usage will just become a problem faster. 8GB is already sometimes a bit small when having many Firefox tabs + one or more IDE instances open.
    – SWdV
    Jun 6, 2020 at 21:28

1 Answer 1

2

I've had this exact issue since Windows 8.1 and it just got worse in Windows 10 (explorer crashing every hour due to using too much memory). Disabled all shell extensions, disable all visual effects, even disabled thumbnails to no avail.

Your comment contained enough clues for me to finally track down the issue, so thank you!

The problem was that I added my home folder to "This PC" and it caused a slow but seemingly exponential growth of DFFACDC5-679F-4156-8947-C5C76BC0B67F handles. Only the home folder is causing the issue, other custom directories are fine. I'm now using Quick Access instead.

3
  • Oh wow! After performing a reinstall solved the issue I reinstalled shell extensions one-by-one, but the problem did not return. Later I used Winaero Tweaker to add my home folder to This PC (which I had done on my old install) and it seemed like the problem maybe returned, so I removed it again and told myself I would investigate it further to confirm later, but I never got around to that. Seems like this was the problem after all, nice find! And odd issue... Interestingly, the CLSID does not seem to open the home folder, do you know what it refers to?
    – SWdV
    Mar 8, 2022 at 17:02
  • Ah wait, nevermind, I forgot the first CLSID description does include "Users Files Folder"
    – SWdV
    Mar 8, 2022 at 17:08
  • This has solved a year long issue for me. Up to this point, I had to restart Explorer at least once a day - after removing the user folder from Explorer's home via Winaero Tweaker, the problem disappeared! Thank you so much! <3
    – ascpixi
    Mar 17 at 18:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .