19

Ubuntu 10.04

Under Preferences > Power Management I have changed the settings to never put the computer to sleep and never to put the display to sleep.

My display still goes to sleep and I am prompted for my password when I leave the computer unattended.

I would like to be able to hit the "Lock Screen" app I added to the top panel to lock my screen, but otherwise I would like it to just stay on.

Thank you.

1
  • 1
    Seems Ubuntu-specific. Should it not be moved to askubuntu.com? (Where I'm pretty sure it would be a dupe.) Oct 23, 2012 at 19:49

6 Answers 6

8

Check System>Preferences>Screensaver and see if "Activate screensaver when computer is idle" is checked.

Also, if you hit Alt + F2 and enter gconf-editor then navigate to /apps/gnome-power-manager/lock you can see if blank screen is checked.

3
  • 1
    Which one out of curiosity?
    – rybl
    Jun 23, 2010 at 18:55
  • 1
    I believe the screensaver setting did the trick. I also did check in /apps/gnome-power-manager/lock and blank screen is not checked.
    – CT.
    Jun 23, 2010 at 19:01
  • The configuration editor shows only /apps/gconf-editor and /apps/schemas/apps/gconf-editor. The both have an entry called bookmarks and nothing else is there.
    – thanos.a
    Apr 29, 2022 at 6:17
11

Things have changed since this post was submitted. Go to System Settings in the top right corner of your screen, select Brightness and Lock and set "turn screen off when inactive" to never.

hope this helps all future users.

1
  • 2
    Nope, doesn't work. The screen still turns off when you lock Jul 5, 2019 at 15:10
5

You can use gsettings for enabling and disabling monitor from going to sleep:

  • Disable turning off screen

    gsettings set org.gnome.desktop.session idle-delay 0

  • Enable turning off screen with 5 min delay

    gsettings set org.gnome.desktop.session idle-delay 300

source : https://askubuntu.com/a/788456/88543

1
  • Also works for PopOS 21.xx
    – Brotzka
    Aug 5, 2021 at 13:52
1

On Ubuntu 20.04.1 LTS you can click on the power button on the top right of your screen, then "Settings", then "Power", then select the "Never" option from the "Blank Screen" drop down.

1
  • 2
    Did so, but it sill goes sleepy
    – Slaus
    Mar 9, 2022 at 14:07
0

Run the following command to disable the monitor turning off when you lock.

gsettings set org.gnome.settings-daemon.plugins.power idle-dim false

Reference: https://itectec.com/ubuntu/ubuntu-how-to-prevent-the-display-from-turning-off-when-screen-is-locked/

Another way is to install the application caffeine and caffeine-indicator from the ubuntu app store.

0

I have found out one solution. Please check if it works. Go to settings at the top right corner. From the left navigation menu,select Power. You will find a panel with the name 'Power Saving Options'. Below that you will find an option 'Automatic suspend'. Click on it and select and deselect according to your preferences. This solution is based on Ubuntu 22.04 OS version.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .