1

I’m looking for a way to capture the real mouse input in a Hyper-V Virtual Machine, so that I can play First Person Shooting games. I'm experiencing a problem where I am spinning around in circles. starting at the floor in games. Any mouse moments I make just makes me spin. I thought maybe it was an issue with my mouse sensitivity, but it wasn't, I continue to spin regardless of what my sensitivity is set too.

I had a read of this forum post and it told me that the VM is not capturing the real mouse input

First of all, the mouse sync driver is primarily designed for you to being able to move your mouse from your host system to the guest system window without having to manually grab the window. It actually 'detects' whether the host mouse cursor is moving on the VM's screen. This mouse is actually not the real mouse cursor, but it’s actually processed by the host system virtual machine to make mouse movement smoother. The sync driver/service just passed the movements to the real vm, but the real vm cursor is actually not there

How can I capture the real mouse input in VM?

  • You do understand that Hyper-V has very limited DirectX support, right? – Ramhound Jun 8 at 23:41
  • running the games is not an issue, the particular game im playing L4D2 doesn't need DirectX 11 support as the game came out in November 2009 so is old and very CPU intensive. But yes your right some newer games like CSGO, that does use DirectX 11 wont run though. But that's not the issue, my problem is trying to get the real mouse input synchronized with the VM. – Ironstone1_ Jun 8 at 23:46
  • Is this a USB mouse? What OS versions for host & guest? – harrymc Jun 12 at 19:57
  • Yes it's USB, my mouse is a Logitech G402, my computer operating system is Windows 10 Pro (64 bit), and the guest OS is also Windows 10 Pro. – Ironstone1_ Jun 12 at 21:08
  • 1
    Try to enable Hyper-V USB Passthrough using Enhanced Session Mode - link1 and link2. If this doesn't work for the mouse, I will recommend other solutions. – harrymc Jun 13 at 8:52
1
+50

The solution that worked for the poster was to enable Hyper-V USB Passthrough using Enhanced Session Mode.

The Microsoft article Use local resources on Hyper-V virtual machine with VMConnect describes these steps:

Turn on enhanced session mode

  • Connect to the computer that hosts the virtual machine.
  • In Hyper-V Manager, select the host's computer name.
  • Select Hyper-V settings.
  • Under Server, select Enhanced session mode policy.
  • Select the Allow enhanced session mode check box.
  • Under User, select Enhanced session mode.
  • Select the Allow enhanced session mode check box.
  • Click OK.

Choose a local resource

  • Open VMConnect
  • Select the virtual machine that you want to connect to
  • Click Show options
  • Select Local resources
  • Click More
  • Choose the devices and resources from this computer to use in the session. USB devices fall under the Plug and Play devices category. Check the corresponding box and click OK.
  • Select Save my settings for future connections to this virtual machine
  • Click Connect.

Another useful reference: Performing Hyper-V USB Passthrough: A Step-By-Step Guide.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.