7

There are long running threads of Office Click-to-Run using excessive CPU (ie 30% or more) continuously, as per this post. The solution in that thread works perfectly for Office 2016, however the cache has been moved in Office 2019 and newer variants of Office 365.

Symptoms:

  • Microsoft Click-to-Run (sxs) runs continuously at ~30%
  • When Office programs have been open for a while, they also start running at ~30%
  • Repairing or reinstalling Office has no effect
  • Using the office uninstaller has no effect
  • Manually removing all Office files from %LocalAppData% and %AppData% etc has no effect
2
  • Recently, I have noticed that many users reported the similar issue, such as Microsoft Office 2019 High CPU Usage after installing an Update. It seems to be related to the specific Office update and version (version 2005 Build 12827.20268 is mentioned most). Some users said that uninstalling and reinstalling an earlier version of Office with offline installer could be a workaround temporarily. Jun 10, 2020 at 8:20
  • Well, in "SxS", there's "excess", so... Just kidding. It's a known issue, that has to do with an update folder constantly refreshing for no reason, and eating your CPU and RAM. You can work around the CPU usage by making sure the process doesn't preempt a core for itself in affinity (right-click on the process in Task Manager, go to Details, Affinity, and check All (cores), so that the load is spread. If that doesn't work, do the opposite, and tie the process to one core in particular. I know it sounds counterintuitive, but Windows has its own way of managing per-process core usage.
    – user1019780
    Jun 12, 2020 at 6:55

7 Answers 7

5

OK, a few possibilities: There may be corrupt cache entries. To clear the cache in Office 2019 / Office 365:

  1. Open the program "Office Upload Centre" with Run as Administrator
  2. Click Settings and Delete Cached Files
  3. Restart the computer

However the issue came back. Even doing a "Reset this PC" didn't help, when I reinstalled Office 365 with the default installer, the issue came back.

The finial fix for me was to install Office 365 32-bit (the default is now 64 bit), and the issue is fixed for now.

0
1

Since I am refusing to disable metered connection (i've this on for the reason to have more control over what gets downloaded/uploaded all the time), i'll add another solution:

You can download Sysinternals Process Explorer (which is a microsoft tool), open it and sort the process list by CPU usage. Then find for example Word and double click on it to open the properties window. You will easily see the thread that is happily eating your cpu cycles away. Just kill this thread. Since its useless telemetry anyway it doesn't seem to affect Word/Excel/etc in any negative way.

Of course this has to be repeated every time you reopen any of the office applicatins.

0

I had the same issue. Updating this week to the latest version seems to have solve the problem. I an now on version 2005 instead of 2004 which was causing the issue.

enter image description here

With Excel, Word, etc showing 16.0.12827.20470 (instead of 16.0.12827.20268).

enter image description hereenter image description here

-1

After all different attempts, I think I fix the problem. It is indeed that the office 365 telemetry is trying to collect data and communicate through network, however, there might be an issue that the connection is not smooth. What you will need to do is add office telemetry dashboard then enable all the telemetry settings. It fixed the connection problem for me, not Click and run keeps very low in the background. I don't think this is the only solution but this problem is a crazy one.

-1

I had the exact same problem for a few days. What helped in my case was to uninstall Microsoft 365 using "Microsoft Support and Recovery Assistant". After letting it run its course, I could reinstall Microsoft 365 and the problem has not resurfaced.

I suspect that it has something to do with making the transition from older office packaging to newer ones.

You might want to try this, unless you are already referring to this tool when you say "Office Uninstaller".

-1

I have Office 365.

Here is what I had done and it works for me:

1- Uninstall Office and Uninstall Skype.

2- Delete "Microsoft Office" and "Microsoft Office 15" folders located in C:\Program Files\

3- In C:\Users\%Username%\AppData\Local\Microsoft\ delete: "Office" folder and "Excel" folder

4- Install Microsoft Office 365.

-2

Click on the WiFi symbol in your task bar, click Properties for your connection, Scroll down, Turn OFF Set as a Metered Connection

Not the answer you're looking for? Browse other questions tagged or ask your own question.