I did a Image Backup of a Windows 10 PC (using the builtin disk image backup feature, called the Windows 7 backup, with system image).

Later I tried to mount the resulting VHDX file, to access some files from the backup.

This used to work in the past (not on this particular backup, but in general). There are many websites describing this procedure, like this one.

But this time it does not work.

If I doubleclick the VHDX file (the biggest one, as usually several are created, the biggest one actually having the data partition) on the file server (Windows 2012 R2 Standard), I get this error:

Couldn’t Mount File

Make sure the file is in an NTFS volume and isn’t in a compressed folder or volume.

If I share the folder containing that file over network and access it from a Windows 8.1 Pro PC (I refer to it as "client" from now on) and doubleclick the VHDX file, I get the same error.

If I try the "Attach VHD" option in Disk Management on the same file, I get:

Virtual Disk Manager

The requested operation could not be completed due to a virtual disk system limitation. On NTFS, virtual hard disk files must be uncompressed and unencrypted. On ReFS, virtual hard disk files must not have the integrity bit set.

Same error if I try locally on server or over network on the client.

If I try on a Windows 10 Pro client, accessing the VHDX file over network, the error is:

Couldn’t Mount File

You don't have permission to mount the file.

But if I copy the file to a local disk (on the win10 PC), it works.

It also works with older backups from a Windows 8.1 PC. They work in all scenarios (local access or over network).

Any idea what is going on?

To recap:

  • the VHDX files from a Windows 10 backup can not be mounted in any case
  • other VHDX files (mostly from Windows 8.1 backups) can be mounted in all cases


Partial solution:

Copying the nonworking VHDX file to a local HDD/SSD makes it mountable:

  • double click it
  • DONE (it assigns a drive letter and shows it in an Explorer window)
  • except if its drive letter overlaps with currently used drive letters, which happens if it is a system drive backup that want to use the C: drive letter; in that case an error pops up:

Couldn’t Mount File

The disk image isn't initialized, contains partitions that aren't recognizable, or contains volumes that haven't been assigned drive letters. Please use the Disk Management snap-in to make sure that the disk, partitions, and volumes are in a usable state.

  • in that case: open Disk Management and assign a (different) drive letter to the mounted VHDX partition(s)
  • I have read your 5 times and I still don’t have know why your question is. The permission error is likely caused by a network trust (file) issue. It’s not clear why your expecting a backup from Windows 10 to be usable in Windows 8.1 – Ramhound Jun 10 '20 at 12:34
  • A vhdx file accessed over a CIFS network share is not an “NTFS volume.” It is a CIFS volume. It’s unclear, but it sounds like you are trying to mount a vhdx file located on a windows file share and it doesn’t work. But if you make the file local, it works. Have you ever done that before? – Appleoddity Jun 10 '20 at 12:54

This is the answer, in the error dialog:

On ReFS, virtual hard disk files must not have the integrity bit set.

The files were on ReFS volume and for some reason, the integrity bit was set on the VHDX file that I had the problem with. The other VHDX files did not have it.

The fix:

In PowerShell run:

Get-Item .\foo.vhdx | Set-FileIntegrity -Enable 0

To check:

Get-Item .\foo.vhdx | Get-FileIntegrity

After this, the file can be mounted locally (currently I can not test remote access).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.