I am using Windows 10 Home on an Acer Swift SF315-41. The wireless adapter is a Qualcomm Atheros QCA61x4A Wireless Network Adapter.

My WiFi was working fine recently, I had no power supply so it was running low on battery. Right around when the battery was around 10-20%, I decided to put it on sleep for a few hours until I got the power supply. After a few hours, I opened the system and the WiFi was gone. I cannot find it in the list of available networks.

This has happened earlier and I used to do this: I went to the device manager and in the network adapter section, would choose Qualcomm Atheros Wireless and I would disable and enable it. This fixed the wireless problem for me.

This time I was unable to find the WiFi adapter in the device manager's network adapter section.

The adapter has both WiFi and Bluetooth modules in it. The Bluetooth is working fine. However, the Bluetooth adapter wont show in Device Manager either, instead it shows "Bluetooth Device(Personal Area Network)".

I tried various ways to fix it, including installing official drivers from the manufacturer's website and updating the BIOS. I also installed a related Windows update: Qualcomm Incorporated - Ports - 3/25/2016 12:00:00 AM -

For further diagnosis, I check Windows Event Viewer and searched for logs around the time of the incident. I found a power log (see below) that corresponds to my issue, and occurred right after the computer came out of sleep mode.

"Miniport Qualcomm Atheros QCA61x4A Wireless Network Adapter, {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}, had event Fatal error: The Miniport has failed a power transition to operational power".

Here is an XML View of the log:

Log Name:      System
Source:        Microsoft-Windows-NDIS
Date:          11-06-2020 04:58:22
Event ID:      10317
Task Category: PnP
Level:         Error
Keywords:      (16384),(16),(4),(2)
User:          N/A
Computer:      LAPTOP-QBHK7CFU
Miniport Qualcomm Atheros QCA61x4A Wireless Network Adapter, {82395df5-aaae-4747-b3b4-c72815243edb}, had event Fatal error: The miniport has failed a power transition to operational power
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <Provider Name="Microsoft-Windows-NDIS" Guid="{cdead503-17f5-4a3e-b7ae-df8cc2902eb9}" />
    <TimeCreated SystemTime="2020-06-10T23:28:22.596539200Z" />
    <Correlation ActivityID="{82395df5-aaae-4747-b3b4-c72815243edb}" />
    <Execution ProcessID="4" ThreadID="17812" />
    <Security />
    <Data Name="IfGuid">{82395df5-aaae-4747-b3b4-c72815243edb}</Data>
    <Data Name="IfIndex">20</Data>
    <Data Name="IfLuid">19985273102270464</Data>
    <Data Name="AdapterName">Qualcomm Atheros QCA61x4A Wireless Network Adapter</Data>
    <Data Name="MiniportEventEnum">74</Data>

I have also seen some other users having a similar problem and some recommended bizarre solutions such as 'Turning off the PC and removing the power cord for 10 seconds' or leave it as it is and Windows will fix it, to updating certain drivers (Since this one was for Intel Adapter, I didn't apply it). I would like a more fundamental solution that I can understand.

I also tried other suggested solutions such as:

  • Reset TCP/IP stack to installation defaults: netsh int ip reset reset.log
  • Reset WINSOCK entries to installation defaults: netsh winsock reset catalog
  • Checking if the hardware is detected or not using 3rd party applications (neither WiFi adapter nor Bluetooth adapter were detected.

I assumed the issue was closely related to power. But now it seems to me that a software issue is more likely.

Please suggest how I should fix this?


So I tried the method of running it in a different OS, and I tried it both on my dual boot system (On Ubuntu) and a bootable usb drive. And the wifi did NOT connect, in fact it showed wifi adapter not found in settings!

Losing all hope, and I was quite convinced that this is a hardware issue, I switched off the PC for a few hours, even removed the power cord and after that, I booted into Ubuntu again, and there it was working again. I have read a similar fix working for some user, i.e., switching off the PC and removing the power cord for 10 seconds did the job for them. Unfortunately, 10 seconds didn't work for, but a few hours did!

I would still like to know possible reasons on this.

  • 1
    Could you clarify this sentence for me? "The main result is, I saw the Windows Event Viewer and searched for logs. ". Is this event from directly after the issue occurred, or is this an event that happened after installing the Windows update?
    – BramMooij
    Jun 11, 2020 at 11:03
  • @BramMooij This event is directly after the issue occurred or to be precise I think this log is in fact the error log corresponding to the issue.
    – Zenquiorra
    Jun 11, 2020 at 11:18

1 Answer 1


Original answer

I suspect a hardware problem with the card. I always check this type of problem with a bootable Linux usb stick. That way, you can very easily rule out any software issues. I use a bootable Ubuntu USB (how to 2). It takes little time to make one, and will be much easier than trying to troubleshoot everything that can go wrong in Windows.

If it works under Ubuntu it must be a software issue, and if it doesn't, it must be a hardware issue.

Why I think it's a hardware issue

If it wasn't a hardware problem, the WiFi card would've probably immediately worked in Ubuntu. Also, removing the power cord does not change anything to the software, but has some influence on the hardware. Therefore, the source of the problem must be hardware. Also, I have had seemingly the exact same issue (sometimes it would work days on end, but intervals kept getting shorter), and replacing the WiFi adapter fixed everything permanently.

Further info on the behaviour

Intermittent functioning of a device such as a WiFi adapter is not unheard of when its hardware is failing. It doesn't necessarily fail in a binary way. However, if it fails at a certain point in time, the OS will think it's failed for the remainder of that session. When you reboot, the adapter has another chance to work. Therefore, a WiFi card that works 99% of the time, actually seems quite broken. Every time it breaks for a few seconds, it's broken for the rest of the session.

What to do now

  1. Order a new WiFi card. It's not expensive, and it's not very hard to replace. It will also cost a lot less time than trying to figure out all the software stuff you can try. If you watch this video 3, or the picture below, you will see the WiFi card. You just have to remove the bottom by removing the screws, and use a guitar pick or your nails to release the pastic clips all around. Remove the white and black cable from the WiFi card and remove the screw holding it down. You can just pull it out now.

[] WiFi card circled, adapted from 3

  1. To check more thoroughly (but in my opinion not necessary): if I am correct, it's unlikely that your WiFi card will make it through an extended period of time without failing again. Probably just streaming some video for an extended period will do, but if you have some big files to download, this would be a good time.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .