1

I have a VMWare Workstation virtual machine that seems to only boot into Ubuntu / Grub when you do a boot from firmware.

If I start the VM normal (not booting to firmware first), it will boot into a Grub prompt (recovery?).

Grub Prompt

If I use the boot menu and select the EFI boot option (Ubuntu) or I choose "boot normally", it will boot to the grub screen that boots the OS.

Boot Menu

Grub Boot Menu

I am using EFI boot. Here is the EFI boot setting.

EFI Settings

What am I doing wrong? I have tried installing boot-repair on the Ubuntu os and it says it is successful. I have also tried removing all boot options, manually adding boot options (I have tried nearly every .efi option under \EFI, and I have also tried letting boot-repair add the EFI option. Of course, I can boot into the OS using the boot menu but I would like to not do that.

0
+50

A very similar problem is detailed in the post GRUB starts in command line after reboot, where Grub booted to the Rescue console.

Check first if the boot information in the UEFI/BIOS looks garbled, and remove unknown partitions and reset the boot order.

A highly upvoted answer treated the case where Grub cannot find the root partition that contains the startup data and have shown how to reset it:

  • In the console, list all available devices using the command ls

  • For each device, list its partition by commands such as ls (hd0,1)/ and ls (hd0,2)/ until you find one that looks like (hd0,1)/boot/grub or (hd0,1)/grub, or for EFI (hd0,1)/efi/boot/grub or (hd0,1)/efi/grub

  • Set the boot parameters using the correct numbers:

      set prefix=(hd0,1)/grub
      set root=(hd0,1)
      insmod linux
      insmod normal
      normal
    
  • The computer should now boot correctly

  • To complete the Grub information, start a terminal and enter the command
    sudo update-grub.

If this doesn't help, boot Linux through the Super Grub2 disk and reinstall grub-efi as follows :

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=debian --recheck --debug /dev/sda
update-grub
| improve this answer | |
  • Hum... While this didn't work for me, it seems to be the best answer (only answer at the time of this comment) and you found something that I couldn't find when I searched. It did give me some ideas but in the end, I'm just going to redo my install since I didn't get very far in it. – Gabriel Graves Jun 16 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.