I'm trying to install Virtualbox on Mac Catalina. It either fails or hangs and in the console I see these messages:

error   10:46:15.111917+1000    kernel  Sandbox: installd(3456) System Policy: deny(1) file-write-data /Library/Preferences/com.apple.TimeMachine.plist
fault   10:46:15.112121+1000    installd    Couldn't write values for keys (
) in CFPrefsPlistSource<0x7fea7d549d70> (Domain: com.apple.TimeMachine, User: kCFPreferencesAnyUser, ByHost: Yes, Container: (null), Contents Need Refresh: Yes): setting preferences outside an application's container requires user-preference-write or file-write-data sandbox access

Any ideas on how to fix whatever the issue is? I have tried rebooting, running the Virtualbox uninstaller, repeating the install, same result.

2 Answers 2


Check all permissions settings if any have been made by any of the attempted installs, other than that I'd usually say make sure virtualization is turned on, but it is by default in Catalina.

Try uninstalling any programs that may conflict with VBs dynamic disk create service, or anything remotely related to parallels if it's there. Pirated copies of files that edit the hosts file can cause issues, and of course, check the install settings each time slowly to make sure you're not missing anything.

  • Any suggestions on where to look for permission settings that might have been changed?
    – Clyde
    Commented Jun 14, 2020 at 9:54
  • No parallels, no pirated files. This is a relatively clean recent install of Catalina.
    – Clyde
    Commented Jun 14, 2020 at 9:56

This fixed it:

sudo kextcache --clear-staging

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .