0

My mouse wheel sometimes stops working until Windows restart. It does NOT work in browsers (all of these: Chrome, Firefox, Edge - the Chromium one), but works fine in any other program. However, zooming in/out with mouse wheel works fine even in browsers.

I use Windows 10, Logitech Options, everything is up-to-date. The issue is quite old so I am not sure, but I believe it appears with any mouse and computer I have used (Logitech mice, bluetooth, infra, wired) with Windows 10.

Obviously, I cannot find anything reasonable using Google, because my issue is specific and there are tons of other mouse-wheel issues coming up in search results (like not working only in Chrome etc.).

2021-03-08 Update

I have just realized I am no longer experiencing the issue. Lucky me!

Unfortunately I do not know what happened that made it go away. :-(

The only thing that I know of is that I uninstalled Logitech Options software from all my computers (which solved all connection issues I had with Bluetooth devices, but that is for different topic).

I myself think that some underlying bug has been solved in the meantime (whether in Firefox, mouse driver, or Windows I do not know).

3
  • 2
    Update the LogiTech driver. I have a LogiTech M535 Bluetooth mouse (up to date driver) and the Mouse wheel (both scrolling and push to scroll lock) works reliably well. – John Jun 15 '20 at 12:45
  • Logitech options is not mandatory, have you tried removing it? – Máté Juhász Jun 15 '20 at 16:56
  • Please see this reply, the user is on Linux, but they have done an in-depth troubleshoot, it should give you some ideas of what to try to see what works and what doesn't. Can you go through the list of what he has tried (as far as you are able), and do the same and update your post with the results? superuser.com/questions/1197895/… – 5Diraptor Jun 16 '20 at 8:05
-1

If you have a Logitech mouse, try the "Restore Defaults" option from Logitech Options; it worked for me, after experiencing the same symptoms that you get (no scroll wheel on any browser, but works fine everywhere else).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.