0

I have host Windows 10 with Cisco anyconnect VPN to my work net. VirtualBox with Linux Mint.

So when Vpn on host isn't enabled everything works fine. But when I connect vpn, my VM gets access to work net, but all other sites can't be resolved.

VBoxManage modifyvm "VM name" --natdnshostresolver1 on - does not helps, it works for some time but after I reboot host or guest (doesn't remember what I tried already), I can't get access to my vpn network, despite vpn is on.

As I can see dns server added in UI (8.8.8.8) appears in output: systemd-resolve --status

Global
          DNSSEC NTA: 10.in-addr.arpa
                      16.172.in-addr.arpa
                      168.192.in-addr.arpa
                      17.172.in-addr.arpa
                      18.172.in-addr.arpa
                      19.172.in-addr.arpa
                      20.172.in-addr.arpa
                      21.172.in-addr.arpa
                      22.172.in-addr.arpa
                      23.172.in-addr.arpa
                      24.172.in-addr.arpa
                      25.172.in-addr.arpa
                      26.172.in-addr.arpa
                      27.172.in-addr.arpa
                      28.172.in-addr.arpa
                      29.172.in-addr.arpa
                      30.172.in-addr.arpa
                      31.172.in-addr.arpa
                      corp
                      d.f.ip6.arpa
                      home
                      internal
                      intranet
                      lan
                      local
                      private
                      test

Link 3 (enp0s8)
      Current Scopes: none
       LLMNR setting: yes
MulticastDNS setting: no
      DNSSEC setting: no
    DNSSEC supported: no

Link 2 (enp0s3)
      Current Scopes: DNS
       LLMNR setting: yes
MulticastDNS setting: no
      DNSSEC setting: no
    DNSSEC supported: no
         DNS Servers: 172.30.0.14
                      172.30.0.15
                      10.2.2.2
                      8.8.8.8
          DNS Domain: ~.
                      net.mycompany.ru

I don't know how to tell that system to try one more dns. 10.2.2.2 - is my home router - gateway, dns ip. Can it be related with that fact that my home network uses 10.2.2.* addresses?

0

Ok, i found solution. Instead of using VBoxManage modifyvm "VM name" --natdnshostresolver1 off and adding 8.8.8.8 dns.

I did VBoxManage modifyvm "VM name" --natdnshostresolver1 on, lost access to my VPN, and manually added my vpn dns server as additional via GUI. Now looks like it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.