I can connect to my home wifi network with my pc and it works perfectly. But when I try to connect network other than Home Wifi, it shows "Connect, No Internet" including my phone portable hotspot that works with connecting other devices. And there are no exclamation marks on my wifi icons in my task bar application. I googled and tried follows but nothing works:

  1. check "Obtain an IP address automatically" and "Obtain DNS sever address automatically" from Wifi Properties.
  2. Disable anti-virus and Firewall. Restore Firewall setting.
  3. Network Reset.
  4. Window Troubleshoot.
  5. Window Updates.
  6. try following commands from cmd
netsh winsock reset
netsh int ip reset
ipconfig /release 
ipconfig /renew
ipconfig /flushdns

I tried with my Mobile data with USB tethering and didn't work too. But when I connect my phone to Home Wifi and USB tethered to PC, it works. Which means my pc can only access Internet from my home wifi. Please help me how to fix it.

  • Try running DISM from an Admin Command prompt. dism.exe /online /cleanup-image /restorehealth and restart. More likely run a Windows 10 Repair Install: microsoft.com/en-us/software-download/windows10 Windows 10 is running, so click on the Download button (not Upgrade Button, select Run. This will launch the Repair and proceed normally.
    – John
    Jun 18, 2020 at 19:04

2 Answers 2


First, keep on your antivirus or use Windows Defender. Do not run without protection.

Second, check Internet Options.

  • Press Windows, type internet opt, an select Internet Options.
  • On the Security tab, set Internet to Default level.

Third, check that both Internet Protocol Version 4 (TCP/IPv4) and Internet Protocol Version 6 (TCP/IPv6) for each adapter specify Obtain DNS server address automatically is checked. Though you stated, briefly, that you'd done that, you did not go into detail. On some public WiFi providers, I've found the issue you have when the provider blocked a fixed DNS address.

  • Thanks for your answer, sir. In Security tab, Internet is already set to Default level. Both IPv4 and IPv6 are checked too but still doesn't work. Sorry that I missed points in my questions. I tested with many android portable hotspots which can connect each other and works fine. But my pc can't connect them too. Jun 19, 2020 at 3:57

I'm sorry to drag the tech discussion level down, but there are a couple of other things you might try. You might contact whoever the provider is for the wifi. I've run into WiFi "hotspots" that just weren't hot -- the router is on, but not providing Internet connection. I also run into public wifi hotspots that are ostensibly unsecured, but then require an online login through a browser. Theoretically, they are supposed to hijack my browser and take it to their site for disclaimer approval, and possibly a free sign-in (w/ ad for faster service for a price). However, often that doesn't work and I just get no functioning Internet. Usually there's an actual URL that can be typed in to go to their sign-in page.

  • Thanks for answering my question. I also tried with android portable hotspot with my phones which have different ISP and they can connect each other and can share Internet access. But my pc doesn't work with them too. Jun 19, 2020 at 4:06
  • It is certainly an odd situation. I hope you figure out a solution and post it here. I've followed your question.
    – AngelSix
    Jun 22, 2020 at 23:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.