5

I have high end PC but I cannot playback videos smoothly. I have a Intel Core i7 8700K, 16gb RAM and GeForce GTX 1080. I have my PC connected via DisplayPort to HDMI cable to a LG 75UM7110 TV. I must use this cable since that is the only port working in this old GPU. The TV has been set up for maximum speed for PC usage. I used this machine fine for a long time with perfectly smooth playback, even 8k was smooth most of the time. What has changed recently is the TV and a fresh Windows 10 build install (and MPC-HC version update).

For software player my choice is MPC-HC, and will not entertain ideas for alternate players. The player is set to use hardware acceleration (displays Playing [H/W] when playing, indicating successful DXVA acceleration). I playback videos off HDD (3500mb/s SSD also tested). The videos are smooth for some seconds, then lag a little, repeat. There does not seem to be any difference between resolution, high or low bitrates or old/new codecs (from XviD to x265). None run smoothly, but it is difficult to tell if the amount of lag differs. The lag does not extend to playing games. During 4k x265 playback and a whole punch of idle-ish programs my CPU stays within 6-8% (with MPC-HC using 31-33% of that), my HDD at 0-2%, and GPU at 12%. MPC-HC memory usage is steady at 326-328mb.

UPDATE

A friend of mine reproduced the problem with his laptop connected to my LG TV with his own cable, into a different HDMI port. The problem does not appear in his laptop screen, only the duplicate output to the TV. These are some of my TV settings:

  • Picture Mode: Game
  • Sharpness: 0
  • Dynamic Contrast: Off
  • Super Resolution: Off
  • Eye Comfort Mode: Off
  • Energy Saving: Off
  • HDMI Ultra HD Deep Color: Off
  • AI Recommendation: Off
12
  • 1
    Try updating drivers by Driver Booster and install windows latest updates.Can I post this as an answer?
    – EliteX
    Jun 21 '20 at 12:07
  • 1
    I used Driver Boost and no help. I used Driver Fusion and no help.
    – Bricktop
    Jun 21 '20 at 13:39
  • 1
    This may not be relevant, but, in NVIDIA Control Panel, what is the refresh rate set to? Are there other values you could try? Jun 21 '20 at 14:23
  • 1
    I have had this issue with other media players previously, in display options what is your scaling option set to? (This was the issue with VLC in particular.) If not set to 100% restart and try. I will comment again if I can think of the other issues I have had. Also what windows build have you installed? (I believe that the most recent has a long list of issues...).
    – CraftyB
    Jun 22 '20 at 23:26
  • 1
    Try installing a good codecs pack. I recommend the K-Lite Codec Pack.
    – harrymc
    Jun 23 '20 at 7:40
4
+50

Interesting well described question: since only two things have changed, if it's conveniently possible to return to the preUpdated OS configuration, if the situation persists, that would imply something re the new tv; if the previous tv could be put back in, that would imply something with the tv+OS, and if the situation occurs with the updated OS with the previous tv, that would imply the update; maybe try check with the tv manufacturer re possible aspects/ fixes: the manufacturer may be unaware of the situation, especially if associated with the new OS update, and there could be other things that may have been updated in the background, depending on updating aspects, which could mean that something has been changed without the change having been indicated, depending on updating aspects, and so there could be more than two things which have changed: implying tv & OS are both ok. There may be something(s) operating in the background which are causing lag. Cable length & connectors could be a factor, but if it was functioning well previously those may be ok. Try adjusting only one item at a time, then two items at a time etc to isolate the specific set of conditions which is/ are the cause. And maybe redo all settings to be certain they're set where intended. (Excellent, nice that that worked; sometimes toggles may indicate values, yet the actual values may differ: sometimes resetting/ switching them off and backing out & then reentering and setting them to the intended value again sets them to where they're intended!)

3
  • 2
    An answer that is just one longggg sentence is hard to read or evaluate.
    – harrymc
    Jun 23 '20 at 7:38
  • 1
    I found out the TV alone is the reason. Now what? Check the OP for more info on my TV settings.
    – Bricktop
    Jun 23 '20 at 12:41
  • 1
    I used factory reset and went though all the settings again. I'm not sure what I did different but now it seems to work without lag.
    – Bricktop
    Jun 23 '20 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.