4

I had previously disabled Microsoft Edge by changing the name of the executable file (MicrosoftEdge.exe) in the Microsoft.MicrosoftEdge_8wekyb3d8bbwe folder. Then, the new update of Windows fixed this. I tried the same technique, but Edge still works. I renamed the folder and all Edge executables that I can find. You can still launch Edge by typing edge into the search bar.

All searches I have done have given the old methods. Is there a new way to do this?

1
  • There are also services (services.msc) dedicated to updating Edge. Their names start with "Microsoft Edge...". Try to set them to "Disabled".
    – pglpm
    Aug 10 '20 at 17:48
2

I renamed the executable file to disable it. This is a temporary solution that seems to work. Be sure you have a working alternative browser before you do.

The new location of Microsoft Edge is:

C:\Program Files (x86)\Microsoft\Edge\Application\msedge.exe

Rename the file to msedge.ex_ Write down what you did in case you need to undo the changes.

Also, rename the update program at:

C:\Program Files (x86)\Microsoft\EdgeUpdate\MicrosoftEdgeUpdate.exe

Rename the file to MicrosoftEdgeUpdate.ex_

You may need to first kill these tasks in task manager before you can rename the files.

You may need to disable Edge after every major Windows update.

1
  • 1
    "You may need to disable Edge after every major Windows update." - Chromium Edge is not updated through Windows Update. The author appears to be asking about the current version of Microsoft Edge not Legacy Edge. Does your answer apply to the current version of Edge?
    – Ramhound
    Jun 23 '20 at 18:49
0

Either I got lucky, or it's not as complicated as people make it out to be. I simply blocked Edge in my firewall settings and now every link opens in Chrome (My default). Worth a shot...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.