0

All other devices on my Lubuntu 20.04LTS Desktop system hotplug fine, with a message asking if I want to open the device in my file manager. However, as of yesterday, I have lost this when I plug in my Android Samsung GS6 phones. Normally, I'm prompted to "Allow" the connection (on the phone) then if I select "Yes" it will open the file manager prompt. Now, all that happens (on two phones) is that the "charging" indicator comes on.

I have tried the following things and identified that this is an issue with the Lubuntu 20.04LTS Desktop system:

  1. Tried phone 1 with different cable (no dice).
  2. Tried phone 2 with same cable (no dice).
  3. Tried phone 2 with different cable (no dice).
  4. Plugged in USB flash drive (works fine).
  5. Plugged phones into a different Lubuntu 20.04LTS laptop (works fine).
  6. Turned off system (as opposed to reboot) and restarted (no dice).
  7. Tried dialing *#0808# and selecting (then reselecting) MTP - ADB
  8. Ran "lsusb" and can see the phone is recognized: "Bus 001 Device 017: ID 04e8:6860 Samsung Electronics Co., Ltd Galaxy series, misc. (MTP mode)"
  9. Here is the appropriate "dmesg" output:
[45269.216369] usb 1-11: new high-speed USB device number 18 using xhci_hcd
[45269.366168] usb 1-11: New USB device found, idVendor=04e8, idProduct=6860, bcdDevice= 4.00
[45269.366173] usb 1-11: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[45269.366177] usb 1-11: Product: SAMSUNG_Android
[45269.366180] usb 1-11: Manufacturer: SAMSUNG
[45269.366182] usb 1-11: SerialNumber: 04157df4a262a410

I have a feeling that either a recent update (the system has been updating frequently) OR my own fiddling while trying to get a USB connection to a DSLR. (Installed v4l2loopback, gphoto2, etc.) I would greatly appreciate any help in getting this working again.

  • It could also be an update of the phone OS/software causing the issue, e.g. a dialog on phone requiring confirmation. See us.community.samsung.com/t5/Galaxy-S-Phones/…, or a driver change, blog.vacs.fr/index.php?post/2010/12/24/… – DrMoishe Pippik Jun 25 at 18:45
  • Thank you, @DrMoishePippik, for the thought -- but if so, why would it work fine on another Lubuntu 20.04LTS system? I feel like it's more likely an issue with the desktop, not the phones. (Though at this point I'm willing to consider anything!) – confused Jun 25 at 19:31
  • And, no, @DrMoishePippik, it's definitely neither of the issues you've linked to. I am able to see (and change) the USB menu on the phone, but simply nothing ever shows up on the computer. USB file transfer, Image Transfter, nothing works. And the other link from 2011 I'd already carefully checked, trying a number of the solutions there -- none worked. – confused Jun 25 at 19:33
  • 1
    Try to purge and reinstall the packages mtp-tools and mtpfs. More possibilities are go-mtpfs and libmtp. Try afterward to run mtp-detect. Ensure that the phone's screen is unlocked when testing. – harrymc Jun 28 at 20:19
  • Halfway there. Doing "mtp-detect" brings up a "Do you want to allow the connection?" dialog on my phone, but when I click "Allow" nothing happens and I don't see anything in the file manager. – confused Jun 29 at 3:56
0

Here's what fixed it: Yesterday I awoke to find a "Upgrade" popup. When I did and rebooted, it worked. Thank you for the help and suggestions. I suspect it was just something borked with a previous upgrade and they identified the issue and fixed it. Before that...everything I tried failed.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.