1

I have an SSD and a HDD on Windows 10 Home prebuilt desktop PC. Windows is on the Samsung SSD. My internal Toshiba HDD shows up as removable:

Ejectable HDD

I am trying to make this no longer be the case, without removing the "safely remove hardware and eject media" tray icon entirely.

I have tried many solutions on the internet and from this site, including the one where I edit the registry value TreatAsInternalPort under Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\Parameters\Device, giving it a multi-string value of 0 (my device is listed as being under Bus Number 0, Target Id 2, LUN 0), but that did nothing. The thing is, a lot of the solutions have their target ID as 0, but for me, it's 2, and if it's relevant, I also seem to have a DVD drive under the same bus number of 0 but as target ID 4 (it doesn't show up as ejectable).

I have also tried looking into my BIOS for HotPlug settings or similar, but did not find such a setting.

I tried updating my "Intel(R) 300 Series Chipset Family SATA AHCI Controller" driver, which it did, then restarted, but the issue persists.

My motherboard is a Lenovo 36e9. Both hard drives appear to use default Microsoft-provided drivers dated 21 Jun 2006.

14
  • 1
    I think you have hit the nail on the head, DVD drive under the same bus number... I had this problem with two drives before, Windows was observing G:\USB External drive and G:\DVD. I opened Device Manager and removed the G: DVD drive and rebooted, make sure you have no USB drives, etc., plugged in before you reboot. Worked for me. Good Luck.
    – vssher
    Jun 28, 2020 at 1:52
  • Hi @vssher, the DVD drive (or maybe it's more accurate to call it a DVD reader) is also internal, built into the case. I have never tried using it before as the PC is rather new and I have not needed to use it yet. Is your solution still applicable; should I give it a try?
    – Cloud
    Jun 28, 2020 at 1:59
  • Yes, just make sure you reboot after removing the DVD drive from within Windows Device Manager, you might also want to go into BIOS and do a hardware check, making sure that it detects all of the drives. I would not recommend messing with the Registry, unless you are used to editing it.
    – vssher
    Jun 28, 2020 at 2:03
  • Forgive me, I've never done this before, but under the "Device Manager", I don't seem to see the DVD drive itself listed (only its driver under "DVD/CD-ROM drives"?), though I do see it under "Devices and Printers" in the control panel with an admin option to "Remove Device". Is that correct?
    – Cloud
    Jun 28, 2020 at 2:05
  • Click on the VIEW (Alt + V) then choose Devices by Connection. You should see DVD/CD ROM drives or similiar. Find the device and right-click on it, choose, remove. Then restart your computer. ;-) You might need to Look under PCI bus.
    – vssher
    Jun 28, 2020 at 2:08

1 Answer 1

0

Right-click your Start menu, and choose "RUN" type in compmgmt.msc. When Computer Management opens you see, in the left field, Storage -> Disk Management. You should see all the drives to your system in the center field. Under volume you should be able to right-click the drive (DVD) and choose from the list, Change Drive Letter and Path... You can place a drive letter on your DVD there, if it does not have one.

Do Not change the drive letter of your Windows operating system.

5
  • After uninstalling just the DVD drive again, this time without other drives plugged in, I noticed that both my HDD and the DVD drive are curiously listed under "Bus Number 0, Target Id 4, LUN 0", but both have different drive letters (D and E respectively) and appear to be working fine. Should I try uninstalling both this time? My worry is for something to go wrong and for my HDD to no longer be recognised over a comparatively minor issue.
    – Cloud
    Jun 28, 2020 at 3:10
  • Under the DVD drive's Properties > Volumes and running "Populate", it did and still does not have a drive letter there despite computer management listing it as E, so I suppose my checking was wrongly done earlier. That's where I was "getting" my drive letters. My HDD did show a "D" under that menu.
    – Cloud
    Jun 28, 2020 at 3:12
  • @Cloud have you seen this page? windowsreport.com/windows-10-thinks-hard-drive-removable There are like, 6 suggestions there which may help. I would not recommend you edit the Registry. Here is also a very good site: tenforums.com/drivers-hardware/…
    – vssher
    Jun 28, 2020 at 3:19
  • I have tried most of those listed in the sites, and have been to the first site before. Save for updating my motherboard's BIOS drivers as I read that it can be risky. Again, don't wish to brick my PC over a comparatively minor issue.
    – Cloud
    Jun 28, 2020 at 3:25
  • Regarding the HDD target id 4 thing, looks like that was a mistake on my part, it is still at a value of 2, same as before. I will try uninstalling both the DVD drive and the HDD in device manager, reboot, and see what happens. If the HDD still shows up as removable, I'm not sure what else to try. Edit: I have done so, same bus numbers, same target IDs, issue persists.
    – Cloud
    Jun 28, 2020 at 3:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .