0

Sorry for the boring problem but I'm pulling my hair out. I've read loads and tried loads from various linux sites but I just can't seem to get it right. I'm trying to mount a CIFS share I have on a NetgearNAS which works perfectly with windows and Android devices. I've changed an old laptop to run Linux Mint as I'm a bit sick of Windows and finally got round to doing something.

So Linux came up easily, I can browse my network and see the NetGearNas with the file manager and I can click on it then drill down to use the shares, files etc. Happy days.... I thought it was surprisingly easy. But oh..... I want to permanently map this access so I can use it in Plex.

smbclient -U sophie -L 192.168.1.41

checking the network share exists for the username result in

    Sharename       Type      Comment
    ---------       ----      -------
    IPC$            IPC       IPC Service (NetGearNAS)
    test            Disk      
    squid           Disk      
    media           Disk      Media Server Share
    backup          Disk      Backup Share
    Videos          Disk      shared video library
    SophieHome      Disk      Sophies data files
    RobHome         Disk      data files for beaumonr
    Photos          Disk      shared photo library
    Music           Disk      shared music library
    MediaBeaumonts  Disk      
    Sophie          Disk      Private user folder
Reconnecting with SMB1 for workgroup listing.

    Server               Comment
    ---------            -------

    Workgroup            Master
    ---------            -------
    WORKGROUP            FREEBOX

So I am tring to use the command

sudo mount -t cifs -vvv //192.168.1.41/Photos /mnt/NetGearPhotos \
           -o username=sophie,password=PASSWORD,uid=1000,noperm,dir_mode=0777,file_mode=077

I want to place the mount point in a directory called /mnt/NetGearPhotos which I have created.
But I get this error

mount.cifs kernel mount options: ip=192.168.1.41,unc=\\192.168.1.41\Photos,noperm,dir_mode=0777,file_mode=077,uid=1000,user=sophie,pass=********
mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

I've tried a lot of stuff and read a lot of "similar posts" but can't seem to get it to connect which is infuriating as I can see and use it in the file manager without any problems at all. Ultimately I want to have it automatically mounted every time it boots but I need to walk before running.

I know its something simple I feel so thick I can't work it out.
Any guidance will be much appreciated.

just tried mounting straight into /mnt and /mnt/ with no sub directory, but get the same result in each case

rob@Dell-6320:~$ sudo mount -t cifs -vvv //192.168.1.41/Photos/ /mnt -o username=sophie,password=yamaha,uid=1000,noperm,dir_mode=0777,file_mode=077
mount.cifs kernel mount options: ip=192.168.1.41,unc=\\192.168.1.41\Photos,noperm,dir_mode=0777,file_mode=077,uid=1000,user=sophie,pass=********
mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Here's my Linux Mint Version number

NAME="Linux Mint"
VERSION="19.3 (Tricia)"
ID=linuxmint
ID_LIKE=ubuntu
PRETTY_NAME="Linux Mint 19.3"
VERSION_ID="19.3"

   Static hostname: Dell-6320
         Icon name: computer-laptop
           Chassis: laptop
        Machine ID: 775ccb91c8f84539a863dbbb02766c59
           Boot ID: dca1c123ecc2435f8a3ff0c5b5dc1fb9
  Operating System: Linux Mint 19.3
            Kernel: Linux 5.4.0-39-generic
      Architecture: x86-64

  • /mnt/NetGearPhotos or /MNT/NetGearPhotos ? typo ? – EchoMike444 Jun 29 at 3:28
  • Ah sorry, that typo was in the forum post not the command. No I've checked all command line cases are the same. In fact I copied and pasted the share and directory paths from the info bar in file manager to avoid that very problem. Just tried again to reconfirm... same error unfortunately. – Rob Jun 29 at 11:22
  • please update your post :) – EchoMike444 Jun 29 at 13:20
  • you are sure that the folder /mnt/NetGearPhotos is present ? – EchoMike444 Jun 29 at 13:20
  • Hi,I corrected the typo in the original post.... Yes I can confirm the directory exists exactly as the path in the command. I also just tried creating another directory /mnt/NetG then used that in the command line but I get exactly the same results. One point, when using the File Manager app to create the directory I noticed that I didn't have the right to create a new directory under /mnt as my standard user, I had to open File Manager as root to be able to create it. Is this normal as I don't recall doing that when I created the original /mnt/NetGearPhotos folder? – Rob Jun 29 at 19:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.