After updating my Arch system, everything by KDE started breaking, from SDDM taking almost 50s to start up to compositing issues. I've tried removing ~/.config/plasma-org.kde.plasma.desktop-appletsrc and resetting settings, to no avail. Even the battery plasmoid is showing no batteries available. How can I fix these issues?


I spent a week trying all kinds of fixes, to no avail. It turns out that the issue is with UPower.

Everything in KDE relies on it for some unknown reason. I found that upower -d failed to output anything, so I checked that upowerd was running, via systemd. It was not, and had crashed on start.

I tried manually running it via

sudo /usr/lib/upowerd --verbose

The output said the libplist dependency was missing. I checked via yay libplist, and found that I had the git version installed from the AUR. Upon installing extra/libplist, which replaced the git version, both sudo /usr/lib/upowerd --verbose and sudo systemctl start upowerd worked with no issues.

It was like a miracle. After a quick reboot (SDDM launched super fast), every trace of lag and crash was gone from every part of KDE. Just like that.

As you can probably tell, I wrote this question for my answer. I hope this helps you one way or another. Good luck fixing your system!

Note to self: check back here if this ever happens again :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.