0

My laptop is a gaming laptop with 128 GB SSD + 1 TB HDD with 4 GB Nvidia 1050 ti and 8 gb ram.

I first tried to install mint on my laptop where I followed the normal path, first disabled hibernation, removed backup security to remove the unmovable things on my D: drive then shrunk the volume by 120 gb. I needed more space so installed a software called aomei diskpart and then used it to increase that 120 to 250 GB.

Then using the same software I made 3 partitions of the unallocated data

1] 25 GB for root: This was logical and ext4

2] 8 GB for swap: ext4 as well

3] 217 GB for home: logical also ext

Then I used rufus to make a bootable falsh drive, then I went into the bios and changed RAID on --> SATA AHCI, I had previously enabled safeboot - minimal mode and then I changed that back to normal after booting into safemode.

Problems when I tried Installing Mint

  1. The first problem was where to install the bootloader. I hadn't touched that setting when installing mint and linux installed it in nvme01p1 or something like that. That gave me an error which said

Sorry, an error occured and it was not possible to install the bootloader at the specified location.

so I tried to do this https://askubuntu.com/questions/430831/bootloader-location but it won't let me click ok. Nothing would happen even after clicking okay multiple times. I waite for like 40 - 45 minutes just to make sure nothing is happening and nothing happened. Held the power button down and restarted my laptop.

  1. This time I installed keeping all settings the same except I installed the bootloader on the ATA SATA (my hdd) and everything went fine until the end and then it said that it was sorry but the installer failed and boom everything froze. I had no option but to again hold my power button down and restart. Tried multiple times but to no avail.

Problems when installing ubuntu

  1. First of all during the partition selection time my laptop's cursor would freeze and I had to navigate using tab and enter and arrow keys.

  2. Similar bootloader problem. It asked me to create another partition of atleast 1mb for the bootloader so I went back and tried to do that but then it would hang and freeze. It was stuck for atleast 30 min. After that I gave up and booted to my windows.

New contributor
RealSlimShady is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

RealSlimShady is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.